Threat landscape
high

Ruby on Rails: Schwachstelle ermöglicht Codeausführung

WID-SEC-2022-0662 · first 13.07.2022 · updated 12.05.2026 · CVSS 10,0

×

What it is about

Ruby on Rails ist ein in der Programmiersprache Ruby geschriebenes und quelloffenes Web Application Framework. Ein entfernter Angreifer kann eine Schwachstelle in Ruby on Rails ausnutzen, um beliebigen Programmcode auszuführen.

Under what conditions?

Over the network.

What can happen in the worst case

An attacker could use the vulnerability to

  • beliebigen Programmcode auszuführen

Am I affected?

Affected according to the BSI:

  • Debian Linux
  • Red Hat Enterprise Linux
  • Gentoo Linux
  • Open Source Ruby on Rails <7.0.3.1
  • Open Source Ruby on Rails <6.1.6.1
  • Open Source Ruby on Rails <6.0.5.1
  • Open Source Ruby on Rails <5.2.8.1
  • SUSE openSUSE

The installed version is usually shown under “Help → About” or in the device’s admin interface.

What helps?

Update to at least:

  • Open Source Ruby on Rails 7.0.3.1
  • Open Source Ruby on Rails 6.1.6.1
  • Open Source Ruby on Rails 6.0.5.1
  • Open Source Ruby on Rails 5.2.8.1

Is the vulnerability already being exploited?

None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.

Information and sources

CVE: CVE-2022-32224

Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.

Set up in an hour, trained in a week.

Create a free account, add your team, unlock the course. You only pay when you start. Would you rather see what a test email looks like first? The self-test is free.

Add your team Test it yourself first