Threat landscape
high

vim: Mehrere Schwachstellen

WID-SEC-2022-2222 · first 05.12.2022 · updated 19.01.2026 · CVSS 7,8

×

What it is about

Vim (Vi IMproved) ist eine Weiterentwicklung des Texteditors vi. Ein lokaler Angreifer kann mehrere Schwachstellen in vim ausnutzen, um beliebigen Programmcode mit Benutzerrechten auszuführen oder einen Denial of Service zu verursachen.

Under what conditions?

Only with access to the device or an account on it. Often the second step after a phishing email.

What can happen in the worst case

An attacker could use the vulnerability to

  • beliebigen Programmcode mit Benutzerrechten auszuführen oder einen Denial of Service zu verursachen

Am I affected?

Affected according to the BSI:

  • Amazon Linux 2
  • Ubuntu Linux
  • SUSE Linux
  • Open Source vim <9.0.0789
  • NetApp ActiveIQ Unified Manager

The installed version is usually shown under “Help → About” or in the device’s admin interface.

What helps?

Update to at least:

  • Open Source vim 9.0.0789

Is the vulnerability already being exploited?

None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.

Information and sources

CVE: CVE-2022-3491, CVE-2022-3520, CVE-2022-3591

Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.

Set up in an hour, trained in a week.

Create a free account, add your team, unlock the course. You only pay when you start. Would you rather see what a test email looks like first? The self-test is free.

Add your team Test it yourself first