Threat landscape
high exploited

GitLab: Mehrere Schwachstellen

WID-SEC-2023-2788 · first 01.11.2023 · updated 30.01.2026 · CVSS 8,1

×

What it is about

GitLab ist eine Webanwendung zur Versionsverwaltung für Softwareprojekte auf Basis von git. Ein Angreifer kann mehrere Schwachstellen in GitLab ausnutzen, um einen Denial of Service Angriff durchzuführen und Informationen offenzulegen.

Under what conditions?

The BSI does not name any particular preconditions. Exploitable remotely according to the BSI.

What can happen in the worst case

An attacker could use the vulnerability to

  • einen Denial of Service Angriff durchzuführen
  • Informationen offenzulegen

Am I affected?

Affected according to the BSI:

  • Open Source GitLab <16.5.1
  • Open Source GitLab <16.4.2
  • Open Source GitLab <16.3.6

The installed version is usually shown under “Help → About” or in the device’s admin interface.

What helps?

Update to at least:

  • Open Source GitLab 16.5.1
  • Open Source GitLab 16.4.2
  • Open Source GitLab 16.3.6

Is the vulnerability already being exploited?

Information and sources

CVE: CVE-2023-3246, CVE-2023-3399, CVE-2023-38545, CVE-2023-3909, CVE-2023-44487, CVE-2023-4700, CVE-2023-5600, CVE-2023-5825, CVE-2023-5831, CVE-2023-5963

Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.

Set up in an hour, trained in a week.

Create a free account, add your team, unlock the course. You only pay when you start. Would you rather see what a test email looks like first? The self-test is free.

Add your team Test it yourself first