GitLab: Mehrere Schwachstellen
WID-SEC-2023-3041 · first 01.12.2023 · updated 04.02.2026 · CVSS 8,7
What it is about
GitLab ist eine Webanwendung zur Versionsverwaltung für Softwareprojekte auf Basis von git. Ein entfernter Angreifer kann mehrere Schwachstellen in GitLab ausnutzen, um Sicherheitsmaßnahmen zu umgehen, einen Denial-of-Service-Zustand herbeizuführen, vertrauliche Informationen offenzulegen, Dateien zu manipulieren, seine Berechtigungen zu erweitern oder XSS-Angriffe durchzuführen.
Under what conditions?
Over the network.
What can happen in the worst case
An attacker could use the vulnerability to
- Sicherheitsmaßnahmen zu umgehen
- einen Denial-of-Service-Zustand herbeizuführen
- vertrauliche Informationen offenzulegen
- Dateien zu manipulieren
- seine Berechtigungen zu erweitern oder XSS-Angriffe durchzuführen
Am I affected?
Affected according to the BSI:
- Open Source GitLab <16.6.1
- Open Source GitLab <16.5.3
- Open Source GitLab <16.4.3
- RESF Rocky Linux
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source GitLab 16.6.1
- Open Source GitLab 16.5.3
- Open Source GitLab 16.4.3
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- GitLab Security Release vom 2023-11-30 about.gitlab.com
- Rocky Linux Security Advisory RLSA-2023:7884 vom 2026-02-03 errata.build.resf.org
CVE: CVE-2022-41409, CVE-2023-3401, CVE-2023-3443, CVE-2023-39417, CVE-2023-3949, CVE-2023-3964, CVE-2023-4317, CVE-2023-4658, CVE-2023-4912, CVE-2023-5226, CVE-2023-5995, CVE-2023-6033, CVE-2023-6396
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.