Red Hat Enterprise Linux (Flatpak): Schwachstelle ermöglicht Codeausführung
WID-SEC-2024-1398 · first 18.06.2024 · updated 14.10.2026 · CVSS 8,4
What it is about
Red Hat Enterprise Linux (RHEL) ist eine populäre Linux-Distribution. Ein lokaler Angreifer kann eine Schwachstelle in Red Hat Enterprise Linux ausnutzen, um beliebigen Programmcode auszuführen.
Under what conditions?
Only with access to the device or an account on it. Often the second step after a phishing email.
What can happen in the worst case
An attacker could use the vulnerability to
- beliebigen Programmcode auszuführen
Am I affected?
Affected according to the BSI:
- Red Hat Enterprise Linux
- SUSE Linux
- Oracle Linux
- Gentoo Linux
- RESF Rocky Linux
- Red Hat Enterprise Linux 9
- Red Hat Enterprise Linux 9.2
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 8.8
- Red Hat Enterprise Linux 8.4
- Red Hat Enterprise Linux 8.6
- Red Hat Enterprise Linux flatpak <1.15.8
and 4 more
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Red Hat Enterprise Linux flatpak 1.15.8
- Red Hat Enterprise Linux flatpak 1.10.9
- Red Hat Enterprise Linux flatpak 1.12.9
- Red Hat Enterprise Linux flatpak 1.14.6
- Juniper Junos Space 24.1R2
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- Juniper Security Advisory JSA92874 vom 2024-01-09 supportportal.juniper.net
- RedHat Security Advisory vom 2024-06-17 access.redhat.com
- RedHat Security Advisory vom 2024-06-17 access.redhat.com
- RedHat Security Advisory vom 2024-06-17 access.redhat.com
- RedHat Security Advisory vom 2024-06-17 access.redhat.com
- RedHat Security Advisory vom 2024-06-17 access.redhat.com
- RedHat Security Advisory vom 2024-06-17 access.redhat.com
- RedHat Security Advisory vom 2024-06-17 access.redhat.com
- GitHub Database github.com
- Oracle Linux Security Advisory ELSA-2024-3961 vom 2024-06-18 linux.oracle.com
- Oracle Linux Security Advisory ELSA-2024-3959 vom 2024-06-18 linux.oracle.com
- Red Hat Security Advisory RHSA-2024:3979 vom 2024-06-18 access.redhat.com
- Red Hat Security Advisory RHSA-2024:3980 vom 2024-06-18 access.redhat.com
- Oracle Linux Security Advisory ELSA-2024-3980 vom 2024-06-18 linux.oracle.com
- SUSE Security Update SUSE-SU-2024:2067-1 vom 2024-06-18 lists.opensuse.org
- Gentoo Linux Security Advisory GLSA-202406-02 vom 2024-06-22 security.gentoo.org
- Rocky Linux Security Advisory RLSA-2024:3961 vom 2024-07-02 errata.build.resf.org
- Rocky Linux Security Advisory RLSA-2024:3959 vom 2024-07-02 errata.build.resf.org
- Oracle Linux Security Advisory ELSA-2026-35843 vom 2026-10-14 linux.oracle.com
CVE: CVE-2024-32462
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.