docker: Schwachstelle ermöglicht Privilegieneskalation
WID-SEC-2024-1703 · first 24.07.2024 · updated 30.03.2026 · CVSS 9,9
What it is about
Docker ist eine Open-Source-Software, die dazu verwendet werden kann, Anwendungen mithilfe von Betriebssystemvirtualisierung in Containern zu isolieren. Ein entfernter, authentisierter Angreifer kann eine Schwachstelle in docker ausnutzen, um seine Privilegien zu erhöhen.
Under what conditions?
Over the network, but only with valid access (login required), for example with stolen credentials or as an insider.
What can happen in the worst case
An attacker could use the vulnerability to
- seine Privilegien zu erhöhen
Am I affected?
Affected according to the BSI:
- Debian Linux
- Amazon Linux 2
- Red Hat Enterprise Linux
- Ubuntu Linux
- SUSE Linux
- SUSE openSUSE
- Open Source docker Desktop <4.33
- Open Source docker <=19.03.15
- Open Source docker <=20.10.27
- Open Source docker <=23.0.14
- Open Source docker <=24.0.9
- Open Source docker <=25.0.5
and 8 more
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source docker Desktop 4.33
- Open Source docker <=19.03.15
- Open Source docker <=20.10.27
- Open Source docker <=23.0.14
- Open Source docker <=24.0.9
- Open Source docker <=25.0.5
- Open Source docker <=26.0.2
- Open Source docker <=26.1.4
- Open Source docker <=27.0.3
- Open Source docker <=27.1.0
- Dell PowerProtect Data Domain 8.4.0.0
- Dell PowerProtect Data Domain 7.10.1.70
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- Docker Security Advisory vom 2024-07-23 www.docker.com
- GitHub Advisory Database github.com
- Amazon Linux Security Advisory ALASNITRO-ENCLAVES-2024-041 vom 2024-07-31 alas.aws.amazon.com
- Amazon Linux Security Advisory ALASDOCKER-2024-040 vom 2024-07-31 alas.aws.amazon.com
- SUSE Security Update SUSE-SU-2024:2709-1 vom 2024-08-02 lists.suse.com
- SUSE Security Update SUSE-SU-2024:2801-1 vom 2024-08-07 lists.suse.com
- SUSE Security Update SUSE-SU-2024:2801-2 vom 2024-08-07 lists.suse.com
- Amazon Linux Security Advisory ALASECS-2024-042 vom 2024-09-03 alas.aws.amazon.com
- SUSE Security Update SUSE-SU-2024:3120-1 vom 2024-09-03 lists.suse.com
- Amazon Linux Security Advisory ALAS-2024-2630 vom 2024-09-05 alas.aws.amazon.com
- Debian Security Advisory DLA-3918 vom 2024-10-13 lists.debian.org
- openSUSE Security Update OPENSUSE-SU-2024:14446-1 vom 2024-11-02 lists.opensuse.org
- SUSE Security Update SUSE-SU-2024:4205-1 vom 2024-12-05 lists.suse.com
- SUSE Security Update SUSE-SU-2024:4204-1 vom 2024-12-05 lists.opensuse.org
- SUSE Security Update SUSE-SU-2024:4319-1 vom 2024-12-16 lists.suse.com
- Ubuntu Security Notice USN-7161-1 vom 2024-12-16 ubuntu.com
- SUSE Security Update SUSE-SU-2024:4360-1 vom 2024-12-17 lists.opensuse.org
- SUSE Security Update SUSE-SU-2025:0226-1 vom 2025-01-23 lists.suse.com
- Ubuntu Security Notice USN-7161-2 vom 2025-02-18 ubuntu.com
- SUSE Security Update SUSE-SU-2025:1062-1 vom 2025-03-31 lists.suse.com
- SUSE Security Update SUSE-SU-2025:1102-1 vom 2025-04-02 lists.suse.com
- Red Hat Security Advisory RHSA-2025:3714 vom 2025-04-09 access.redhat.com
- Ubuntu Security Notice USN-7161-3 vom 2025-04-15 ubuntu.com
- SUSE Security Update SUSE-SU-2025:20259-1 vom 2025-06-04 lists.suse.com
- SUSE Security Update SUSE-SU-2025:20110-1 vom 2025-06-04 lists.suse.com
and 6 more sources in the original advisory
CVE: CVE-2024-41110
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.