Drupal: Schwachstelle ermöglicht Ausführen von beliebigem Programmcode mit den Rechten des Dienstes
WID-SEC-2024-1938 · first 19.11.2020 · updated 24.08.2026 · CVSS 9,8
What it is about
Drupal ist ein freies Content-Management-System, basierend auf der Scriptsprache PHP und einer SQL-Datenbank. Über zahlreiche Extensions kann der Funktionsumfang der Core-Installation individuell erweitert werden. Ein entfernter, anonymer Angreifer kann eine Schwachstelle in Drupal ausnutzen, um beliebigen Programmcode mit den Rechten des Dienstes auszuführen.
Under what conditions?
Over the network and without logging in. This is the most dangerous combination: attackers can scan reachable devices automatically.
What can happen in the worst case
An attacker could use the vulnerability to
- beliebigen Programmcode mit den Rechten des Dienstes auszuführen
Am I affected?
Affected according to the BSI:
- Debian Linux
- Ubuntu Linux
- Open Source Drupal <9.0.8
- Open Source Drupal <8.9.9
- Open Source Drupal <8.8.11
- Open Source Drupal <7.74
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source Drupal 9.0.8
- Open Source Drupal 8.9.9
- Open Source Drupal 8.8.11
- Open Source Drupal 7.74
Is the vulnerability already being exploited?
- CVE-2020-13671: exploited in the wild according to CISA, in the catalogue since 18.01.2022.
Information and sources
- Original BSI advisory (WID)
- Drupal Security Advisory vom 2020-11-18 www.drupal.org
- Debian Security Advisory DLA-2458 vom 2020-11-19 lists.debian.org
- Ubuntu Security Notice USN-6981-1 vom 2024-08-27 ubuntu.com
- Ubuntu Security Notice USN-6981-2 vom 2024-09-03 ubuntu.com
- PoC CVE-2020-13671 vom 2026-08-23 github.com
CVE: CVE-2020-13671
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.