Threat landscape
critical

PHP: Mehrere Schwachstellen

WID-SEC-2024-2230 · first 27.09.2024 · updated 22.10.2026 · CVSS 9,8

×

What it is about

PHP ist eine Programmiersprache, die zur Implementierung von Web-Applikationen genutzt wird. Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in PHP ausnutzen, um beliebigen Programmcode auszuführen, Informationen preiszugeben und andere nicht spezifizierte Angriffe durchzuführen.

Under what conditions?

Over the network and without logging in. This is the most dangerous combination: attackers can scan reachable devices automatically.

What can happen in the worst case

An attacker could use the vulnerability to

  • beliebigen Programmcode auszuführen
  • Informationen preiszugeben, andere nicht spezifizierte Angriffe durchzuführen

Am I affected?

Affected according to the BSI:

  • Debian Linux
  • Amazon Linux 2
  • Red Hat Enterprise Linux
  • Ubuntu Linux
  • SUSE Linux
  • Oracle Linux
  • Gentoo Linux
  • RESF Rocky Linux
  • Open Source PHP <8.2.24
  • Open Source PHP <8.3.12
  • NetApp Data ONTAP 9

The installed version is usually shown under “Help → About” or in the device’s admin interface.

What helps?

Update to at least:

  • Open Source PHP 8.2.24
  • Open Source PHP 8.3.12

Is the vulnerability already being exploited?

None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.

Information and sources

and 6 more sources in the original advisory

CVE: CVE-2024-8925, CVE-2024-8926, CVE-2024-8927, CVE-2024-9026

Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.

Set up in an hour, trained in a week.

Create a free account, add your team, unlock the course. You only pay when you start. Would you rather see what a test email looks like first? The self-test is free.

Add your team Test it yourself first