Ansible: Schwachstelle ermöglicht Privilegieneskalation
WID-SEC-2024-3358 · first 07.11.2024 · updated 08.06.2026 · CVSS 6,8
What it is about
Ansible ist eine Software zur Automatisierung von Cloud Provisionierung, zum Konfigurationsmanagement und zur Anwendungsbereitstellung. Ein lokaler Angreifer kann eine Schwachstelle in Ansible ausnutzen, um seine Privilegien zu erhöhen.
Under what conditions?
Only with access to the device or an account on it. Often the second step after a phishing email.
What can happen in the worst case
An attacker could use the vulnerability to
- seine Privilegien zu erhöhen
Am I affected?
Affected according to the BSI:
- Debian Linux
- Red Hat Enterprise Linux
- SUSE openSUSE
- Open Source Ansible <2.14.18rc1
- Open Source Ansible <2.15.13rc1
- Open Source Ansible <2.16.13rc1
- Open Source Ansible <2.17.6rc1
- Open Source Ansible <2.18.0rc2
- Red Hat Ansible Automation Platform
- Red Hat Ansible Automation Platform 2.5
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source Ansible 2.14.18rc1
- Open Source Ansible 2.15.13rc1
- Open Source Ansible 2.16.13rc1
- Open Source Ansible 2.17.6rc1
- Open Source Ansible 2.18.0rc2
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- GitHub Advisory Database vom 2024-11-06 github.com
- NIST Vulnerability Database vom 2024-11-06 nvd.nist.gov
- Red Hat Bugzilla vom 2024-11-06 bugzilla.redhat.com
- Red Hat vom 2024-11-06 access.redhat.com
- openSUSE Security Update OPENSUSE-SU-2024:14499-1 vom 2024-11-16 lists.opensuse.org
- Red Hat Security Advisory RHSA-2024:9894 vom 2024-11-18 access.redhat.com
- Debian Security Advisory DLA-3963 vom 2024-11-24 lists.debian.org
- openSUSE Security Update OPENSUSE-SU-2024:14537-1 vom 2024-12-03 lists.opensuse.org
- Red Hat Security Advisory RHSA-2024:10762 vom 2024-12-03 access.redhat.com
- Red Hat Security Advisory RHSA-2025:1861 vom 2025-02-25 access.redhat.com
- openSUSE Security Update OPENSUSE-SU-2025:15754-1 vom 2025-11-22 lists.opensuse.org
- openSUSE Security Update OPENSUSE-SU-2026:10945-1 vom 2026-06-07 lists.opensuse.org
CVE: CVE-2024-9902
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.