Ruby on Rails: Mehrere Schwachstellen ermöglichen Cross-Site Scripting
WID-SEC-2024-3665 · first 11.12.2024 · updated 18.03.2026 · CVSS 6,1
What it is about
Ruby on Rails ist ein in der Programmiersprache Ruby geschriebenes und quelloffenes Web Application Framework. Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in Ruby on Rails ausnutzen, um einen Cross-Site Scripting Angriff durchzuführen.
Under what conditions?
Over the network and without logging in. This is the most dangerous combination: attackers can scan reachable devices automatically.
What can happen in the worst case
An attacker could use the vulnerability to
- einen Cross-Site Scripting Angriff durchzuführen
Am I affected?
Affected according to the BSI:
- Debian Linux
- SUSE openSUSE
- Open Source Ruby on Rails <7.0.8.7
- Open Source Ruby on Rails <7.1.5.1
- Open Source Ruby on Rails <7.2.2.1
- Open Source Ruby on Rails <8.0.0.1
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source Ruby on Rails 7.0.8.7
- Open Source Ruby on Rails 7.1.5.1
- Open Source Ruby on Rails 7.2.2.1
- Open Source Ruby on Rails 8.0.0.1
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- Rails Versions 7.0.8.7, 7.1.5.1, 7.2.2.1, and 8.0.0.1 vom 2024-12-10 rubyonrails.org
- openSUSE Security Update OPENSUSE-SU-2025:14677-1 vom 2025-01-22 lists.opensuse.org
- openSUSE Security Update OPENSUSE-SU-2025:14673-1 vom 2025-01-22 lists.opensuse.org
- openSUSE Security Update OPENSUSE-SU-2025:14668-1 vom 2025-01-22 lists.opensuse.org
- openSUSE Security Update OPENSUSE-SU-2025:14671-1 vom 2025-01-22 lists.opensuse.org
- openSUSE Security Update OPENSUSE-SU-2025:14679-1 vom 2025-01-22 lists.opensuse.org
- openSUSE Security Update OPENSUSE-SU-2025:14676-1 vom 2025-01-22 lists.opensuse.org
- openSUSE Security Update OPENSUSE-SU-2025:14672-1 vom 2025-01-22 lists.opensuse.org
- openSUSE Security Update OPENSUSE-SU-2025:14680-1 vom 2025-01-22 lists.opensuse.org
- openSUSE Security Update OPENSUSE-SU-2025:14674-1 vom 2025-01-22 lists.opensuse.org
- Debian Security Advisory DSA-5881 vom 2025-03-17 lists.debian.org
- Debian Security Advisory DLA-4383 vom 2025-11-25 lists.debian.org
- openSUSE Security Update OPENSUSE-SU-2026:10335-1 vom 2026-03-15 lists.opensuse.org
- openSUSE Security Update OPENSUSE-SU-2026:10337-1 vom 2026-03-15 lists.opensuse.org
- openSUSE Security Update OPENSUSE-SU-2026:10339-1 vom 2026-03-15 lists.opensuse.org
- openSUSE Security Update OPENSUSE-SU-2026:10341-1 vom 2026-03-15 lists.opensuse.org
- openSUSE Security Update OPENSUSE-SU-2026:10344-1 vom 2026-03-16 lists.opensuse.org
- openSUSE Security Update OPENSUSE-SU-2026:10345-1 vom 2026-03-16 lists.opensuse.org
- openSUSE Security Update OPENSUSE-SU-2026:10360-1 vom 2026-03-17 lists.opensuse.org
- openSUSE Security Update OPENSUSE-SU-2026:10362-1 vom 2026-03-17 lists.opensuse.org
CVE: CVE-2024-53847, CVE-2024-54133
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.