PyTorch: Schwachstelle ermöglicht Codeausführung
WID-SEC-2025-0857 · first 22.04.2025 · updated 20.03.2026 · CVSS 9,8
What it is about
PyTorch ist eine Tensor-Bibliothek für Deep Learning mit GPUs und CPUs. Ein entfernter, anonymer Angreifer kann eine Schwachstelle in PyTorch ausnutzen, um beliebigen Programmcode auszuführen.
Under what conditions?
Over the network and without logging in. This is the most dangerous combination: attackers can scan reachable devices automatically.
What can happen in the worst case
An attacker could use the vulnerability to
- beliebigen Programmcode auszuführen
Am I affected?
Affected according to the BSI:
- Debian Linux
- Open Source PyTorch <2.6.0
- Open Source PyTorch <=2.5.1
- Open Source Elasticsearch <9.1.8
- Open Source Elasticsearch <8.19.8
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source PyTorch 2.6.0
- Open Source PyTorch <=2.5.1
- Open Source Elasticsearch 9.1.8
- Open Source Elasticsearch 8.19.8
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- GitHub Security Advisory vom 2025-04-21 github.com
- NIST CVE-2025-32434 nvd.nist.gov
- PoC vom 2025-11-23 github.com
- Debian Security Advisory DLA-4389 vom 2025-12-01 lists.debian.org
- Elastic Security Announcement ESA-2026-18 vom 2026-03-19 discuss.elastic.co
CVE: CVE-2025-32434
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.