Bootstrap: Schwachstelle ermöglicht Cross-Site Scripting
WID-SEC-2025-1072 · first 16.05.2025 · updated 09.10.2026 · CVSS 5,0
What it is about
Bootstrap ist ein HTML-, CSS- und JavaScript-Framework für die Entwicklung responsiver Webprojekte. Ein entfernter, anonymer Angreifer kann eine Schwachstelle in Bootstrap ausnutzen, um einen Cross-Site Scripting Angriff durchzuführen.
Under what conditions?
Over the network and without logging in. This is the most dangerous combination: attackers can scan reachable devices automatically.
What can happen in the worst case
An attacker could use the vulnerability to
- einen Cross-Site Scripting Angriff durchzuführen
Am I affected?
Affected according to the BSI:
- Debian Linux
- Amazon Linux 2
- Open Source Bootstrap <4.0.0
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source Bootstrap 4.0.0
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- NIST Vulnerability Database vom 2025-05-15 nvd.nist.gov
- European Union Vulnerability Databse vom 2025-05-15 euvd.enisa.europa.eu
- PoC auf herodevs vom 2025-05-15 www.herodevs.com
- Debian Security Advisory DLA-4204 vom 2025-06-01 lists.debian.org
- Amazon Linux Security Advisory ALAS2-2025-2995 vom 2025-09-16 alas.aws.amazon.com
- Debian Security Advisory DLA-4830 vom 2026-10-09 lists.debian.org
- Debian Security Advisory DLA-1479 vom 2026-10-09 security-tracker.debian.org
CVE: CVE-2025-1647
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.