PHP: Mehrere Schwachstellen
WID-SEC-2025-1460 · first 04.07.2025 · updated 22.10.2026 · CVSS 8,2
What it is about
PHP ist eine Programmiersprache, die zur Implementierung von Web-Applikationen genutzt wird. Ein Angreifer kann mehrere Schwachstellen in PHP ausnutzen, um Denial of Service oder Server-Side Request-Forgery Angriffe durchzuführen.
Under what conditions?
The BSI does not name any particular preconditions. Exploitable remotely according to the BSI.
What can happen in the worst case
An attacker could use the vulnerability to
- Denial of Service oder Server-Side Request-Forgery Angriffe durchzuführen
Am I affected?
Affected according to the BSI:
- Debian Linux
- Amazon Linux 2
- Red Hat Enterprise Linux
- Fedora Linux
- Ubuntu Linux
- SUSE Linux
- Oracle Linux
- SUSE openSUSE
- RESF Rocky Linux
- Xerox FreeFlow Print Server v7
- Open Source PHP <8.1.33
- Open Source PHP <8.2.29
and 8 more
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source PHP 8.1.33
- Open Source PHP 8.2.29
- Open Source PHP 8.3.23
- Open Source PHP 8.4.10
- cPanel cPanel/WHM 110.0.70
- cPanel cPanel/WHM 118.0.52
- cPanel cPanel/WHM 126.0.27
- cPanel cPanel/WHM 128.0.17
- cPanel cPanel/WHM 130.0.3
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- PHP 8 Changelog vom 2025-07-03 www.php.net
- PHP 8.1.33 Release vom 2025-07-03 php.net
- PHP 8.2.29 Release vom 2025-07-03 php.net
- PHP 8.3.23 Release vom 2025-07-03 php.net
- PHP 8.4.10 Release vom 2025-07-03 php.net
- GitHub PHP Security Advisory GHSA-3cr5-j632-f35r vom 2025-07-03 mit PoC github.com
- GitHub PHP Security Advisory GHSA-hrwm-9436-5mv3 vom 2025-07-03 github.com
- GitHub PHP Security Advisory GHSA-453j-q27h-5p8x vom 2025-07-03 mit PoC github.com
- Fedora Security Advisory FEDORA-2025-2C344545BF vom 2025-07-04 bodhi.fedoraproject.org
- Fedora Security Advisory FEDORA-2025-DA047483D8 vom 2025-07-04 bodhi.fedoraproject.org
- openSUSE Security Update OPENSUSE-SU-2025:15340-1 vom 2025-07-12 lists.opensuse.org
- cPanel Change Log vom 2025-07-16 docs.cpanel.net
- cPanel Change Log vom 2025-07-16 docs.cpanel.net
- cPanel Change Log vom 2025-07-16 docs.cpanel.net
- cPanel Change Log vom 2025-07-16 docs.cpanel.net
- cPanel Change Log vom 2025-07-16 docs.cpanel.net
- Ubuntu Security Notice USN-7648-1 vom 2025-07-17 ubuntu.com
- SUSE Security Update SUSE-SU-2025:02462-1 vom 2025-07-22 lists.suse.com
- SUSE Security Update SUSE-SU-2025:02463-1 vom 2025-07-22 lists.suse.com
- SUSE Security Update SUSE-SU-2025:02473-1 vom 2025-07-23 lists.suse.com
- SUSE Security Update SUSE-SU-2025:02474-1 vom 2025-07-23 lists.suse.com
- Debian Security Advisory DLA-4254 vom 2025-07-27 lists.debian.org
- Debian Security Advisory DSA-5967 vom 2025-07-29 lists.debian.org
- Amazon Linux Security Advisory ALAS2PHP8.2-2025-008 vom 2025-08-05 alas.aws.amazon.com
- Amazon Linux Security Advisory ALAS2PHP8.1-2025-007 vom 2025-08-05 alas.aws.amazon.com
and 16 more sources in the original advisory
CVE: CVE-2025-1220, CVE-2025-1735, CVE-2025-6491
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.