Threat landscape
low

vim (.tar and .zip): Mehrere Schwachstellen ermöglichen Codeausführung

WID-SEC-2025-1575 · first 16.07.2025 · updated 31.08.2026 · CVSS 4,1

×

What it is about

Vim (Vi IMproved) ist eine Weiterentwicklung des Texteditors vi. Ein lokaler Angreifer kann mehrere Schwachstellen in vim ausnutzen, um beliebigen Programmcode auszuführen oder um beliebige Dateien zu überschreiben.

Under what conditions?

Only with access to the device or an account on it. Often the second step after a phishing email.

What can happen in the worst case

An attacker could use the vulnerability to

  • beliebigen Programmcode auszuführen oder um beliebige Dateien zu überschreiben

Am I affected?

Affected according to the BSI:

  • Red Hat Enterprise Linux
  • Fedora Linux
  • Ubuntu Linux
  • SUSE Linux
  • Oracle Linux
  • Gentoo Linux
  • IBM QRadar SIEM
  • SUSE openSUSE
  • RESF Rocky Linux
  • Open Source vim <9.1.1551
  • Open Source vim <9.1.1552
  • Dell Secure Connect Gateway Appliance <5.32.00.18

The installed version is usually shown under “Help → About” or in the device’s admin interface.

What helps?

Update to at least:

  • Open Source vim 9.1.1551
  • Open Source vim 9.1.1552
  • Dell Secure Connect Gateway Appliance 5.32.00.18

Is the vulnerability already being exploited?

None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.

Information and sources

and 27 more sources in the original advisory

CVE: CVE-2025-53905, CVE-2025-53906

Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.

Set up in an hour, trained in a week.

Create a free account, add your team, unlock the course. You only pay when you start. Would you rather see what a test email looks like first? The self-test is free.

Add your team Test it yourself first