Flowise: Mehrere Schwachstellen
WID-SEC-2025-2048 · first 15.09.2025 · updated 10.07.2026 · CVSS 10,0
What it is about
Flowise ist eine Benutzeroberfläche zur Erstellung von LLMs (Large Language Model). Ein Angreifer kann mehrere Schwachstellen in Flowise ausnutzen, um beliebigen Programmcode auszuführen, und um Informationen offenzulegen.
Under what conditions?
The BSI does not name any particular preconditions. Exploitable remotely according to the BSI.
What can happen in the worst case
An attacker could use the vulnerability to
- beliebigen Programmcode auszuführen
- Informationen offenzulegen
Am I affected?
Affected according to the BSI:
- Open Source Flowise <3.0.6
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source Flowise 3.0.6
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- Flowise GitHub vom 2025-09-14 github.com
- Flowise GitHub vom 2025-09-14 github.com
- Flowise GitHub vom 2025-09-14 github.com
- Flowise GitHub vom 2025-09-14 github.com
- Flowise GitHub vom 2025-09-14 github.com
- Flowise GitHub vom 2025-09-14 github.com
- Flowise GitHub vom 2025-09-14 github.com
CVE: CVE-2025-58434, CVE-2025-71324, CVE-2025-71336
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.