Threat landscape
medium

VMware Tanzu Spring Framework und Spring Security: Mehrere Schwachstellen ermöglichen Umgehen von Sicherheitsvorkehrungen

WID-SEC-2025-2060 · first 16.09.2025 · updated 26.10.2026 · CVSS 7,5

×

What it is about

Spring Security ist ein Framework, das Authentifizierung, Autorisierung und Schutz vor gängigen Angriffen bietet. Das Spring Framework bietet ein Entwicklungsmodell für Java mit Infrastrukturunterstützung auf Anwendungsebene. Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in VMware Tanzu Spring Security und VMware Tanzu Spring Framework ausnutzen, um Sicherheitsvorkehrungen zu umgehen.

Under what conditions?

Over the network and without logging in. This is the most dangerous combination: attackers can scan reachable devices automatically.

What can happen in the worst case

An attacker could use the vulnerability to

  • Sicherheitsvorkehrungen zu umgehen

Am I affected?

Affected according to the BSI:

  • IBM InfoSphere Information Server 11.7
  • Red Hat Enterprise Linux
  • IBM Operational Decision Manager
  • IBM SPSS Collaboration and Deployment Services
  • IBM Sterling Connect:Direct
  • VMware Tanzu Spring Security <6.4.10
  • VMware Tanzu Spring Security <6.5.4
  • VMware Tanzu Spring Framework <6.2.11
  • Red Hat Integration Apache Camel <4.10.7 for Spring Boot
  • HCL Commerce <25.09.17.0
  • Dell Secure Connect Gateway Appliance <5.32.00.18
  • Atlassian Bitbucket <10.0.2

and 9 more

The installed version is usually shown under “Help → About” or in the device’s admin interface.

What helps?

Update to at least:

  • VMware Tanzu Spring Security 6.4.10
  • VMware Tanzu Spring Security 6.5.4
  • VMware Tanzu Spring Framework 6.2.11
  • Red Hat Integration Apache Camel 4.10.7 for Spring Boot
  • HCL Commerce 25.09.17.0
  • Dell Secure Connect Gateway Appliance 5.32.00.18
  • Atlassian Bitbucket 10.0.2
  • Atlassian Bitbucket 8.19.25 (LTS)
  • Atlassian Bitbucket 9.4.13 (LTS)
  • Atlassian Confluence 10.1.1
  • Atlassian Confluence 10.0.2
  • Atlassian Confluence 9.2.7

Is the vulnerability already being exploited?

None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.

Information and sources

CVE: CVE-2025-41248, CVE-2025-41249

Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.

Set up in an hour, trained in a week.

Create a free account, add your team, unlock the course. You only pay when you start. Would you rather see what a test email looks like first? The self-test is free.

Add your team Test it yourself first