GitLab: Mehrere Schwachstellen
WID-SEC-2025-2587 · first 13.11.2025 · updated 15.01.2026 · CVSS 7,7
What it is about
GitLab ist eine Webanwendung zur Versionsverwaltung für Softwareprojekte auf Basis von git. Ein entfernter, authentisierter Angreifer kann mehrere Schwachstellen in GitLab ausnutzen, um Cross-Site-Scripting-Angriffe durchzuführen, vertrauliche Informationen offenzulegen, die Authentifizierung zu umgehen, Daten zu manipulieren oder einen Denial-of-Service-Zustand zu verursachen.
Under what conditions?
Over the network, but only with valid access (login required), for example with stolen credentials or as an insider.
What can happen in the worst case
An attacker could use the vulnerability to
- Cross-Site-Scripting-Angriffe durchzuführen
- vertrauliche Informationen offenzulegen
- die Authentifizierung zu umgehen
- Daten zu manipulieren oder einen Denial-of-Service-Zustand zu verursachen
Am I affected?
Affected according to the BSI:
- Open Source GitLab <18.5.2
- Open Source GitLab <18.4.4
- Open Source GitLab <18.3.6
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source GitLab 18.5.2
- Open Source GitLab 18.4.4
- Open Source GitLab 18.3.6
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- GitLab Patch Release vom 2025-11-12 about.gitlab.com
CVE: CVE-2024-55549, CVE-2025-11224, CVE-2025-11865, CVE-2025-11990, CVE-2025-12983, CVE-2025-24855, CVE-2025-2615, CVE-2025-6171, CVE-2025-6945, CVE-2025-7000, CVE-2025-7736
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.