Threat landscape
high

vllm und PyTorch: Schwachstelle ermöglicht DoS und potenzielle Codeausführung

WID-SEC-2025-2666 · first 24.11.2025 · updated 21.05.2026 · CVSS 8,8

×

What it is about

Open Source vLLM ist eine Open-Source-Bibliothek für schnelle und effiziente Inferenz von Large Language Models (LLMs). PyTorch ist eine Tensor-Bibliothek für Deep Learning mit GPUs und CPUs. Ein entfernter, authentisierter Angreifer kann eine Schwachstelle in vllm und PyTorch ausnutzen, um einen Denial-of-Service-Zustand zu verursachen oder möglicherweise eine Remote-Codeausführung zu erreichen.

Under what conditions?

Over the network, but only with valid access (login required), for example with stolen credentials or as an insider.

What can happen in the worst case

An attacker could use the vulnerability to

  • einen Denial-of-Service-Zustand zu verursachen oder möglicherweise eine Remote-Codeausführung zu erreichen

Am I affected?

Affected according to the BSI:

  • Red Hat Enterprise Linux
  • Open Source vllm <0.11.1
  • Open Source PyTorch >=2.8.0

The installed version is usually shown under “Help → About” or in the device’s admin interface.

What helps?

Update to at least:

  • Open Source vllm 0.11.1
  • Open Source PyTorch >=2.8.0

Is the vulnerability already being exploited?

None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.

Information and sources

CVE: CVE-2025-62164

Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.

Set up in an hour, trained in a week.

Create a free account, add your team, unlock the course. You only pay when you start. Would you rather see what a test email looks like first? The self-test is free.

Add your team Test it yourself first