Apache Struts: Schwachstelle ermöglicht Denial of Service
WID-SEC-2025-2704 · first 02.12.2025 · updated 18.03.2026 · CVSS 7,5
What it is about
Struts ist ein Framework für Java-Anwendungen auf dem Webserver Apache. Ein entfernter, anonymer Angreifer kann eine Schwachstelle in Apache Struts ausnutzen, um einen Denial of Service Angriff durchzuführen.
Under what conditions?
Over the network and without logging in. This is the most dangerous combination: attackers can scan reachable devices automatically.
What can happen in the worst case
An attacker could use the vulnerability to
- einen Denial of Service Angriff durchzuführen
Am I affected?
Affected according to the BSI:
- IBM Tivoli Netcool/OMNIbus 8.1.0
- Apache Struts <6.8.0
- Apache Struts <7.1.1
- Apache Struts 2.0.0-6.7.4
- Atlassian Bamboo <12.1.3 (LTS)
- Atlassian Bamboo <10.2.16 (LTS)
- Atlassian Bamboo <9.6.24 (LTS)
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Apache Struts 6.8.0
- Apache Struts 7.1.1
- Atlassian Bamboo 12.1.3 (LTS)
- Atlassian Bamboo 10.2.16 (LTS)
- Atlassian Bamboo 9.6.24 (LTS)
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- Apache Struts Security Bulletin S2-068 vom 2025-12-01 cwiki.apache.org
- Red Hat Bugtracker #2418059 vom 2025-12-01 bugzilla.redhat.com
- Seclists Mailing vom 2025-12-01 seclists.org
- CVE-2025-66675 vom 2025-12-09 www.cve.org
- IBM Security Bulletin 7261892 vom 2026-02-26 www.ibm.com
- Atlassian Security Bulletin - March 17 2026 confluence.atlassian.com
CVE: CVE-2025-64775, CVE-2025-66675
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.