Apache Struts (XWork): Schwachstelle ermöglicht Manipulation von Dateien
WID-SEC-2026-0064 · first 12.01.2026 · updated 18.03.2026 · CVSS 6,3
What it is about
Struts ist ein Framework für Java-Anwendungen auf dem Webserver Apache. Ein Angreifer kann eine Schwachstelle in Apache Struts ausnutzen, um Dateien zu manipulieren, vertrauliche Daten offenzulegen oder einen Denial-of-Service-Zustand zu verursachen.
Under what conditions?
The BSI does not name any particular preconditions. Exploitable remotely according to the BSI.
What can happen in the worst case
An attacker could use the vulnerability to
- Dateien zu manipulieren
- vertrauliche Daten offenzulegen oder einen Denial-of-Service-Zustand zu verursachen
Am I affected?
Affected according to the BSI:
- Apache Struts <6.1.1
- Atlassian Bamboo <12.1.3 (LTS)
- Atlassian Bamboo <10.2.16 (LTS)
- Atlassian Bamboo <9.6.24 (LTS)
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Apache Struts 6.1.1
- Atlassian Bamboo 12.1.3 (LTS)
- Atlassian Bamboo 10.2.16 (LTS)
- Atlassian Bamboo 9.6.24 (LTS)
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- GitHub Advisory Database vom 2026-01-11 github.com
- Apache Security Bulletins vom 2026-01-11 cwiki.apache.org
- Atlassian Security Bulletin - March 17 2026 confluence.atlassian.com
CVE: CVE-2025-68493
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.