Kubernetes (ingress-nginx): Schwachstelle ermöglicht Codeausführung und Offenlegung von Informationen
WID-SEC-2026-0330 · first 06.02.2026 · updated 09.02.2026 · CVSS 8,8
What it is about
Kubernetes ist ein Werkzeug zur Automatisierung der Bereitstellung, Skalierung und Verwaltung von containerisierten Anwendungen. Ein entfernter, authentisierter Angreifer kann eine Schwachstelle in Kubernetes ausnutzen, um beliebigen Programmcode auszuführen und vertrauliche Informationen offenzulegen.
Under what conditions?
Over the network, but only with valid access (login required), for example with stolen credentials or as an insider.
What can happen in the worst case
An attacker could use the vulnerability to
- beliebigen Programmcode auszuführen
- vertrauliche Informationen offenzulegen
Am I affected?
Affected according to the BSI:
- Open Source Kubernetes Ingress NGINX <1.12.5
- Open Source Kubernetes Ingress NGINX <1.13.1
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source Kubernetes Ingress NGINX 1.12.5
- Open Source Kubernetes Ingress NGINX 1.13.1
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
CVE: CVE-2025-15566
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.