Drupal Module (UI Icons, Quick Edit): Mehrere Schwachstellen ermöglichen Cross-Site Scripting
WID-SEC-2026-0397 · first 12.02.2026 · updated 26.03.2026 · CVSS 4,6
What it is about
Drupal ist ein freies Content-Management-System, basierend auf der Scriptsprache PHP und einer SQL-Datenbank. Über zahlreiche Extensions kann der Funktionsumfang der Core-Installation individuell erweitert werden. Ein entfernter, authentisierter Angreifer kann mehrere Schwachstellen in Drupal ausnutzen, um einen Cross-Site Scripting Angriff durchzuführen.
Under what conditions?
Over the network, but only with valid access (login required), for example with stolen credentials or as an insider.
What can happen in the worst case
An attacker could use the vulnerability to
- einen Cross-Site Scripting Angriff durchzuführen
Am I affected?
Affected according to the BSI:
- Open Source Drupal Quick Edit <1.0.5
- Open Source Drupal Quick Edit <2.0.1
- Open Source Drupal UI Icons <1.0.1
- Open Source Drupal UI Icons <1.1.1
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source Drupal Quick Edit 1.0.5
- Open Source Drupal Quick Edit 2.0.1
- Open Source Drupal UI Icons 1.0.1
- Open Source Drupal UI Icons 1.1.1
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- Drupal Security Advisory vom 2026-02-11 www.drupal.org
- Drupal Security Advisory vom 2026-02-11 www.drupal.org
CVE: CVE-2026-2348, CVE-2026-2349
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.