Threat landscape
medium

vim (NetBeans): Schwachstelle ermöglicht Codeausführung

WID-SEC-2026-0419 · first 16.02.2026 · updated 04.09.2026 · CVSS 5,4

×

What it is about

Vim (Vi IMproved) ist eine Weiterentwicklung des Texteditors vi. Ein entfernter, anonymer Angreifer kann eine Schwachstelle in vim ausnutzen, um einen Denial-of-Service zu verursachen oder möglicherweise die Ausführung von beliebigem Code zu erreichen.

Under what conditions?

Over the network and without logging in. This is the most dangerous combination: attackers can scan reachable devices automatically.

What can happen in the worst case

An attacker could use the vulnerability to

  • einen Denial-of-Service zu verursachen oder möglicherweise die Ausführung von beliebigem Code zu erreichen

Am I affected?

Affected according to the BSI:

  • Dell NetWorker
  • Fedora Linux
  • Ubuntu Linux
  • SUSE Linux
  • SUSE openSUSE
  • Dell Avamar
  • Open Source vim <v9.1.2148
  • Dell Secure Connect Gateway <5.36.00.16

The installed version is usually shown under “Help → About” or in the device’s admin interface.

What helps?

Update to at least:

  • Open Source vim v9.1.2148
  • Dell Secure Connect Gateway 5.36.00.16

Is the vulnerability already being exploited?

None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.

Information and sources

CVE: CVE-2026-26269

Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.

Set up in an hour, trained in a week.

Create a free account, add your team, unlock the course. You only pay when you start. Would you rather see what a test email looks like first? The self-test is free.

Add your team Test it yourself first