Drupal Extensions: Mehrere Schwachstellen
WID-SEC-2026-0530 · first 26.02.2026 · updated 26.03.2026 · CVSS 8,1
What it is about
Drupal ist ein freies Content-Management-System, basierend auf der Scriptsprache PHP und einer SQL-Datenbank. Über zahlreiche Extensions kann der Funktionsumfang der Core-Installation individuell erweitert werden. Ein entfernter, anonymer oder authentisierter Angreifer kann mehrere Schwachstellen in verschiedenen Drupal Extensions ausnutzen, um Cross-Site-Scripting-Angriffe zu starten, Sicherheitsmaßnahmen zu umgehen, Daten zu manipulieren und vertrauliche Informationen offenzulegen.
Under what conditions?
Over the network and without logging in. This is the most dangerous combination: attackers can scan reachable devices automatically.
What can happen in the worst case
An attacker could use the vulnerability to
- Cross-Site-Scripting-Angriffe zu starten
- Sicherheitsmaßnahmen zu umgehen
- Daten zu manipulieren
- vertrauliche Informationen offenzulegen
Am I affected?
Affected according to the BSI:
- Open Source Drupal Material Icons <2.0.4
- Open Source Drupal CAPTCHA <2.0.10.
- Open Source Drupal CAPTCHA <8.x-1.17.
- Open Source Drupal Theme Negotiation by Rules <1.2.1
- Open Source Drupal Canvas <1.1.1
- Open Source Drupal Islandora <2.17.5
- Open Source Drupal Anti-Spam by CleanTalk <9.7.0
- Open Source Drupal Tagify <1.2.49
- Open Source Drupal SAML SSO-Service Provider <3.1.3
- Open Source Drupal Responsive Favicons <2.0.2
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source Drupal Material Icons 2.0.4
- Open Source Drupal CAPTCHA 2.0.10.
- Open Source Drupal CAPTCHA 8.x-1.17.
- Open Source Drupal Theme Negotiation by Rules 1.2.1
- Open Source Drupal Canvas 1.1.1
- Open Source Drupal Islandora 2.17.5
- Open Source Drupal Anti-Spam by CleanTalk 9.7.0
- Open Source Drupal Tagify 1.2.49
- Open Source Drupal SAML SSO-Service Provider 3.1.3
- Open Source Drupal Responsive Favicons 2.0.2
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- Drupal Security Advisory SA-CONTRIB-2026-011 vom 2026-02-25 www.drupal.org
- Drupal Security Advisory SA-CONTRIB-2026-012 vom 2026-02-25 www.drupal.org
- Drupal Security Advisory SA-CONTRIB-2026-013 vom 2026-02-25 www.drupal.org
- Drupal Security Advisory SA-CONTRIB-2026-014 vom 2026-02-25 www.drupal.org
- Drupal Security Advisory SA-CONTRIB-2026-015 vom 2026-02-25 www.drupal.org
- Drupal Security Advisory SA-CONTRIB-2026-016 vom 2026-02-25 www.drupal.org
- Drupal Security Advisory SA-CONTRIB-2026-017 vom 2026-02-25 www.drupal.org
- Drupal Security Advisory SA-CONTRIB-2026-018 vom 2026-02-25 www.drupal.org
- Drupal Security Advisory SA-CONTRIB-2026-019 vom 2026-02-25 www.drupal.org
CVE: CVE-2026-3212, CVE-2026-3213, CVE-2026-3215, CVE-2026-3217, CVE-2026-3218, CVE-2026-3210, CVE-2026-3214, CVE-2026-3211, CVE-2026-3216
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.