Threat landscape
critical

nginx-ui: Mehrere Schwachstellen

WID-SEC-2026-0931 · first 31.03.2026 · updated 16.04.2026 · CVSS 9,8

×

What it is about

NGINX ist eine Webserver-, Reverse Proxy- und E-Mail-Proxy Software. Ein entfernter, authentisierter Angreifer kann mehrere Schwachstellen in nginx-ui ausnutzen, um sich Administratorrechte zu verschaffen, beliebigen Code auszuführen, Daten zu manipulieren, Sicherheitsmaßnahmen zu umgehen oder einen Denial-of-Service-Zustand herbeizuführen.

Under what conditions?

Over the network, but only with valid access (login required), for example with stolen credentials or as an insider.

What can happen in the worst case

An attacker could use the vulnerability to

  • sich Administratorrechte zu verschaffen
  • beliebigen Code auszuführen
  • Daten zu manipulieren
  • Sicherheitsmaßnahmen zu umgehen oder einen Denial-of-Service-Zustand herbeizuführen

Am I affected?

Affected according to the BSI:

  • NGINX NGINX UI <2.3.4

The installed version is usually shown under “Help → About” or in the device’s admin interface.

What helps?

Update to at least:

  • NGINX NGINX UI 2.3.4

Is the vulnerability already being exploited?

None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.

Information and sources

CVE: CVE-2026-33026, CVE-2026-33027, CVE-2026-33028, CVE-2026-33029, CVE-2026-33030, CVE-2026-33032

Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.

Set up in an hour, trained in a week.

Create a free account, add your team, unlock the course. You only pay when you start. Would you rather see what a test email looks like first? The self-test is free.

Add your team Test it yourself first