Threat landscape
high

vim: Schwachstelle ermöglicht Codeausführung

WID-SEC-2026-0940 · first 01.04.2026 · updated 21.09.2026 · CVSS 8,2

×

What it is about

Vim (Vi IMproved) ist eine Weiterentwicklung des Texteditors vi. Ein entfernter, anonymer Angreifer kann eine Schwachstelle in vim ausnutzen, um beliebigen Programmcode auszuführen.

Under what conditions?

Over the network and without logging in. This is the most dangerous combination: attackers can scan reachable devices automatically.

What can happen in the worst case

An attacker could use the vulnerability to

  • beliebigen Programmcode auszuführen

Am I affected?

Affected according to the BSI:

  • Dell NetWorker
  • Amazon Linux 2
  • Red Hat Enterprise Linux
  • Ubuntu Linux
  • SUSE Linux
  • Oracle Linux
  • SUSE openSUSE
  • RESF Rocky Linux
  • Dell Avamar
  • Red Hat OpenShift Container Platform
  • Microsoft Azure Linux azl3
  • Open Source vim <9.2.0276

and 3 more

The installed version is usually shown under “Help → About” or in the device’s admin interface.

What helps?

Update to at least:

  • Open Source vim 9.2.0276
  • Red Hat Enterprise Linux Cryostat 4.2.0
  • Dell Secure Connect Gateway 5.36.00.16

Is the vulnerability already being exploited?

None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.

Information and sources

and 28 more sources in the original advisory

CVE: CVE-2026-34982

Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.

Set up in an hour, trained in a week.

Create a free account, add your team, unlock the course. You only pay when you start. Would you rather see what a test email looks like first? The self-test is free.

Add your team Test it yourself first