Composer: Mehrere Schwachstellen ermöglichen Codeausführung
WID-SEC-2026-1128 · first 15.04.2026 · updated 17.08.2026 · CVSS 8,8
What it is about
Composer ist ein Open-Source-Abhängigkeitsmanager für PHP-Projekte. Ein Angreifer kann mehrere Schwachstellen in Composer ausnutzen, um beliebigen Programmcode auszuführen.
Under what conditions?
The BSI does not name any particular preconditions. Exploitable remotely according to the BSI.
What can happen in the worst case
An attacker could use the vulnerability to
- beliebigen Programmcode auszuführen
Am I affected?
Affected according to the BSI:
- SUSE Linux
- Open Source Composer <2.9.6
- Open Source Composer LTS <2.2.27
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source Composer 2.9.6
- Open Source Composer LTS 2.2.27
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- GitHub Security Advisory GHSA-gqw4-4w2p-838q vom 2026-04-14 github.com
- GitHub Security Advisory GHSA-wg36-wvj6-r67p vom 2026-04-14 github.com
- SUSE Security Update SUSE-SU-2026:1784-1 vom 2026-05-11 lists.suse.com
- SUSE Security Update SUSE-SU-2026:21542-1 vom 2026-05-11 lists.suse.com
- SUSE Security Update SUSE-SU-2026:1970-1 vom 2026-05-18 lists.suse.com
- SUSE Security Update SUSE-SU-2026:3105-1 vom 2026-07-17 lists.suse.com
- SUSE Security Update SUSE-SU-2026:23138-1 vom 2026-08-14 lists.suse.com
- SUSE Security Update SUSE-SU-2026:23116-1 vom 2026-08-14 lists.suse.com
CVE: CVE-2026-40176, CVE-2026-40261
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.