Nextcloud: Mehrere Schwachstellen
WID-SEC-2026-1517 · first 13.05.2026 · updated 02.06.2026 · CVSS 8,2
What it is about
Nextcloud ist eine "on-premise" Plattform für Dateifreigabe und Zusammenarbeit. Ein Angreifer kann mehrere Schwachstellen in Nextcloud ausnutzen, um Sicherheitsvorkehrungen zu umgehen, um Informationen offenzulegen, und um einen SQL-Injection Angriff durchzuführen.
Under what conditions?
The BSI does not name any particular preconditions. Exploitable remotely according to the BSI.
What can happen in the worst case
An attacker could use the vulnerability to
- Sicherheitsvorkehrungen zu umgehen
- Informationen offenzulegen
- einen SQL-Injection Angriff durchzuführen
Am I affected?
Affected according to the BSI:
- Nextcloud Nextcloud Forms <5.2.7
- Nextcloud Nextcloud Tables <1.0.4
- Nextcloud Nextcloud Tables <2.0.0
- Nextcloud Nextcloud Tables <0.7.7
- Nextcloud Nextcloud Tables <0.8.10
- Nextcloud Nextcloud Tables <0.9.8
- Nextcloud Nextcloud Server <33.0.3
- Nextcloud Nextcloud Server <32.0.9
- Nextcloud Nextcloud Enterprise Server <33.0.3
- Nextcloud Nextcloud Enterprise Server <32.0.9
- Nextcloud Nextcloud Enterprise Server <31.0.14.5
- Nextcloud Nextcloud Enterprise Server <30.0.17.9
and 1 more
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Nextcloud Nextcloud Forms 5.2.7
- Nextcloud Nextcloud Tables 1.0.4
- Nextcloud Nextcloud Tables 2.0.0
- Nextcloud Nextcloud Tables 0.7.7
- Nextcloud Nextcloud Tables 0.8.10
- Nextcloud Nextcloud Tables 0.9.8
- Nextcloud Nextcloud Server 33.0.3
- Nextcloud Nextcloud Server 32.0.9
- Nextcloud Nextcloud Enterprise Server 33.0.3
- Nextcloud Nextcloud Enterprise Server 32.0.9
- Nextcloud Nextcloud Enterprise Server 31.0.14.5
- Nextcloud Nextcloud Enterprise Server 30.0.17.9
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- GitHub Security Advisory GHSA-mp6x-g55j-w9jw vom 2026-05-12 github.com
- GitHub Security Advisory GHSA-q4fw-6jf8-5vhh vom 2026-05-12 github.com
- GitHub Security Advisory GHSA-vvxm-6jjp-m9mp vom 2026-05-12 github.com
- GitHub Security Advisory GHSA-x43f-gmgh-vvjj vom 2026-05-12 github.com
CVE: CVE-2026-45543, CVE-2026-45544, CVE-2026-45545, CVE-2026-45691
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.