Composer: Schwachstelle ermöglicht Offenlegung von Informationen
WID-SEC-2026-1518 · first 13.05.2026 · updated 13.05.2026 · CVSS 7,5
What it is about
Composer ist ein Open-Source-Abhängigkeitsmanager für PHP-Projekte. Ein entfernter, anonymer Angreifer kann eine Schwachstelle in Composer ausnutzen, um Informationen offenzulegen.
Under what conditions?
Over the network and without logging in. This is the most dangerous combination: attackers can scan reachable devices automatically.
What can happen in the worst case
An attacker could use the vulnerability to
- Informationen offenzulegen
Am I affected?
Affected according to the BSI:
- Open Source Composer <2.9.8
- Open Source Composer <2.2.28
- Open Source Composer <1.10.28
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source Composer 2.9.8
- Open Source Composer 2.2.28
- Open Source Composer 1.10.28
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.