nginx-ui: Mehrere Schwachstellen
WID-SEC-2026-2390 · first 17.07.2026 · updated 13.10.2026 · CVSS 8,8
What it is about
nginx-ui ist eine Open-Source-Weboberfläche zur Verwaltung und Konfiguration von Nginx-Webservern. Ein Angreifer kann mehrere Schwachstellen in nginx-ui ausnutzen, um beliebigen Code auszuführen, einschließlich der Codeausführung mit Root-Rechten; erweiterte Rechte zu erlangen; eine Kontoübernahme durchzuführen; Sicherheitsmaßnahmen zu umgehen; oder Daten offenzulegen und zu manipulieren.
Under what conditions?
The BSI does not name any particular preconditions. Exploitable remotely according to the BSI.
What can happen in the worst case
An attacker could use the vulnerability to
- beliebigen Code auszuführen
- einschließlich der Codeausführung mit Root-Rechten; erweiterte Rechte zu erlangen; eine Kontoübernahme durchzuführen; Sicherheitsmaßnahmen zu umgehen; oder Daten offenzulegen und zu manipulieren
Am I affected?
Affected according to the BSI:
- Open Source nginx-ui <2.4.0
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source nginx-ui 2.4.0
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- GitHub Security Advisory GHSA-2gc7-j998-5xx6 vom 2026-07-16 github.com
- GitHub Security Advisory GHSA-44xr-mrhh-qm78 vom 2026-07-16 github.com
- GitHub Security Advisory GHSA-5r62-gj48-897x vom 2026-07-16 github.com
- GitHub Security Advisory GHSA-5v7c-xpfp-p65m vom 2026-07-16 github.com
- GitHub Security Advisory GHSA-76pm-mq2q-9gcr vom 2026-07-16 github.com
- GitHub Security Advisory GHSA-9jww-cxg5-rj9m vom 2026-07-16 github.com
- GitHub Security Advisory GHSA-cf23-7qxj-xmhr vom 2026-07-16 github.com
- GitHub Security Advisory GHSA-gfrc-g87h-7h5w vom 2026-07-16 github.com
- GitHub Security Advisory GHSA-jrq7-xrjx-pcfw vom 2026-07-16 github.com
- GitHub Security Advisory GHSA-vc32-4gwf-77xp vom 2026-07-16 github.com
- GitHub Security Advisory GHSA-wq4w-vwvq-q3x9 vom 2026-07-16 github.com
CVE: CVE-2026-84312, CVE-2026-84313, CVE-2026-84314, CVE-2026-84315, CVE-2026-84316, CVE-2026-84317, CVE-2026-84318, CVE-2026-84319, CVE-2026-84320, CVE-2026-84321, CVE-2026-84360
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.