Ansible: Schwachstelle ermöglicht Codeausführung
WID-SEC-2026-2462 · first 22.07.2026 · updated 19.10.2026 · CVSS 7,8
What it is about
Ansible ist eine Software zur Automatisierung von Cloud Provisionierung, zum Konfigurationsmanagement und zur Anwendungsbereitstellung. Ein lokaler Angreifer kann eine Schwachstelle in Ansible ausnutzen, um beliebigen Programmcode auszuführen.
Under what conditions?
Only with access to the device or an account on it. Often the second step after a phishing email.
What can happen in the worst case
An attacker could use the vulnerability to
- beliebigen Programmcode auszuführen
Am I affected?
Affected according to the BSI:
- Red Hat Enterprise Linux
- SUSE Linux
- SUSE openSUSE
- Open Source Ansible core <2.16.19rc1
- Open Source Ansible core <2.18.18rc1
- Open Source Ansible core <2.19.11rc1
- Open Source Ansible core <2.20.7rc1
- Open Source Ansible core <2.21.1rc1
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source Ansible core 2.16.19rc1
- Open Source Ansible core 2.18.18rc1
- Open Source Ansible core 2.19.11rc1
- Open Source Ansible core 2.20.7rc1
- Open Source Ansible core 2.21.1rc1
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- GitHub Advisory Database vom 2026-07-21 github.com
- Red Hat Security Advisory RHSA-2026:63386 vom 2026-09-04 access.redhat.com
- Red Hat Security Advisory RHSA-2026:63387 vom 2026-09-04 access.redhat.com
- Red Hat Security Advisory RHSA-2026:63385 vom 2026-09-04 access.redhat.com
- openSUSE Security Update OPENSUSE-SU-2026:21828-1 vom 2026-09-11 lists.opensuse.org
- SUSE Security Update SUSE-SU-2026:4154-1 vom 2026-09-16 lists.suse.com
- SUSE Security Update SUSE-SU-2026:23704-1 vom 2026-09-16 lists.suse.com
- SUSE Security Update SUSE-SU-2026:23724-1 vom 2026-09-16 lists.suse.com
- openSUSE Security Update OPENSUSE-SU-2026:12052-1 vom 2026-10-18 lists.opensuse.org
- openSUSE Security Update OPENSUSE-SU-2026:12053-1 vom 2026-10-18 lists.opensuse.org
- openSUSE Security Update OPENSUSE-SU-2026:12054-1 vom 2026-10-18 lists.opensuse.org
- openSUSE Security Update OPENSUSE-SU-2026:12055-1 vom 2026-10-18 lists.opensuse.org
CVE: CVE-2026-16493
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.