vim: Mehrere Schwachstellen
WID-SEC-2026-2513 · first 24.07.2026 · updated 14.10.2026 · CVSS 7,3
What it is about
Vim (Vi IMproved) ist eine Weiterentwicklung des Texteditors vi. Ein Angreifer kann mehrere Schwachstellen in vim ausnutzen, um beliebigen Programmcode auszuführen, um einen Denial of Service Angriff durchzuführen, und um nicht näher spezifizierte Auswirkungen zu verursachen.
Under what conditions?
The BSI does not name any particular preconditions. Exploitable remotely according to the BSI.
What can happen in the worst case
An attacker could use the vulnerability to
- beliebigen Programmcode auszuführen
- einen Denial of Service Angriff durchzuführen, nicht näher spezifizierte Auswirkungen zu verursachen
Am I affected?
Affected according to the BSI:
- Amazon Linux 2
- Red Hat Enterprise Linux
- IBM QRadar SIEM
- RESF Rocky Linux
- SUSE Linux
- SUSE openSUSE
- Oracle Linux
- Open Source vim <9.2.0840
- Open Source vim <9.2.0839
- Open Source vim <9.2.0843
- Open Source vim <9.2.0841
- Open Source vim <9.2.0842
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source vim 9.2.0840
- Open Source vim 9.2.0839
- Open Source vim 9.2.0843
- Open Source vim 9.2.0841
- Open Source vim 9.2.0842
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- Vim GitHub vom 2026-07-23 github.com
- GitHub Security Advisory GHSA-49m8-wwxj-mr69 vom 2026-07-23 github.com
- GitHub Security Advisory GHSA-hm4g-pjfx-m27j vom 2026-07-23 github.com
- GitHub Security Advisory GHSA-pmvp-6rcj-98p4 vom 2026-07-23 github.com
- GitHub Security Advisory GHSA-r5v6-q6j8-8qw2 vom 2026-07-23 github.com
- GitHub Security Advisory GHSA-rcr7-f3wr-22r2 vom 2026-07-23 github.com
- SUSE Security Update SUSE-SU-2026:23190-1 vom 2026-08-24 lists.suse.com
- SUSE Security Update SUSE-SU-2026:23181-1 vom 2026-08-25 lists.suse.com
- openSUSE Security Update OPENSUSE-SU-2026:21671-1 vom 2026-08-29 lists.opensuse.org
- Amazon Linux Security Advisory ALAS2-2026-3882 vom 2026-09-01 alas.aws.amazon.com
- SUSE Security Update SUSE-SU-2026:23393-1 vom 2026-09-10 lists.suse.com
- SUSE Security Update SUSE-SU-2026:23346-1 vom 2026-09-10 lists.suse.com
- Red Hat Security Advisory RHSA-2026:66336 vom 2026-09-10 access.redhat.com
- SUSE Security Update SUSE-SU-2026:23391-1 vom 2026-09-10 lists.suse.com
- SUSE Security Update SUSE-SU-2026:23365-1 vom 2026-09-10 lists.suse.com
- Red Hat Security Advisory RHSA-2026:66348 vom 2026-09-10 access.redhat.com
- Oracle Linux Security Advisory ELSA-2026-66348 vom 2026-09-11 linux.oracle.com
- Red Hat Security Advisory RHSA-2026:66366 vom 2026-09-10 access.redhat.com
- Rocky Linux Security Advisory RLSA-2026:66348 vom 2026-09-11 errata.build.resf.org
- Oracle Linux Security Advisory ELSA-2026-66366 vom 2026-09-11 linux.oracle.com
- Oracle Linux Security Advisory ELSA-2026-66336 vom 2026-09-10 linux.oracle.com
- Rocky Linux Security Advisory RLSA-2026:66366 vom 2026-09-11 errata.build.resf.org
- Rocky Linux Security Advisory RLSA-2026:66336 vom 2026-09-11 errata.build.resf.org
- SUSE Security Update SUSE-SU-2026:23552-1 vom 2026-09-16 lists.suse.com
- Red Hat Security Advisory RHSA-2026:68711 vom 2026-09-17 access.redhat.com
and 23 more sources in the original advisory
CVE: CVE-2026-73078, CVE-2026-73077, CVE-2026-73075, CVE-2026-73074, CVE-2026-73070
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.