PHP: Mehrere Schwachstellen
WID-SEC-2026-2598 · first 31.07.2026 · updated 22.10.2026 · CVSS 9,8
What it is about
PHP ist eine Programmiersprache, die zur Implementierung von Web-Applikationen genutzt wird. Ein Angreifer kann mehrere Schwachstellen in PHP ausnutzen, um SQL-Injection durchzuführen, beliebigen Code auszuführen, Daten zu manipulieren oder einen Denial-of-Service-Zustand auszulösen.
Under what conditions?
The BSI does not name any particular preconditions. Exploitable remotely according to the BSI.
What can happen in the worst case
An attacker could use the vulnerability to
- SQL-Injection durchzuführen
- beliebigen Code auszuführen
- Daten zu manipulieren oder einen Denial-of-Service-Zustand auszulösen
Am I affected?
Affected according to the BSI:
- Debian Linux
- Amazon Linux 2
- Red Hat Enterprise Linux
- RESF Rocky Linux
- SUSE Linux
- SUSE openSUSE
- Ubuntu Linux
- Oracle Linux
- Open Source PHP <8.2.33
- Open Source PHP <8.3.33
- Open Source PHP <8.4.24
- Open Source PHP <8.5.9
and 2 more
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source PHP 8.2.33
- Open Source PHP 8.3.33
- Open Source PHP 8.4.24
- Open Source PHP 8.5.9
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- PHP GitHub vom 2026-07-30 github.com
- PHP GitHub vom 2026-07-30 github.com
- PHP GitHub vom 2026-07-30 github.com
- Debian Security Advisory DSA-6406 vom 2026-08-01 security-tracker.debian.org
- openSUSE Security Update OPENSUSE-SU-2026:11418-1 vom 2026-08-02 lists.opensuse.org
- Amazon Linux Security Advisory ALAS2PHP8.2-2026-013 vom 2026-08-05 alas.aws.amazon.com
- SUSE Security Update SUSE-SU-2026:3509-1 vom 2026-08-05 lists.suse.com
- SUSE Security Update SUSE-SU-2026:3510-1 vom 2026-08-05 lists.suse.com
- SUSE Security Update SUSE-SU-2026:3514-1 vom 2026-08-06 lists.suse.com
- SUSE Security Update SUSE-SU-2026:3513-1 vom 2026-08-06 lists.suse.com
- openSUSE Security Update OPENSUSE-SU-2026:21532-1 vom 2026-08-06 lists.opensuse.org
- Debian Security Advisory DLA-4733 vom 2026-08-12 lists.debian.org
- Debian Security Advisory DLA-4732 vom 2026-08-12 lists.debian.org
- SUSE Security Update SUSE-SU-2026:23144-1 vom 2026-08-14 lists.suse.com
- SUSE Security Update SUSE-SU-2026:23121-1 vom 2026-08-14 lists.suse.com
- Zend CVE-2026-17543 vom 2026-08-17 www.zend.com
- Zend CVE-2026-17544 vom 2026-08-17 www.zend.com
- Zend CVE-2026-7260 vom 2026-08-17 www.zend.com
- Oracle Linux Security Advisory ELSA-2026-56969 vom 2026-08-20 linux.oracle.com
- Red Hat Security Advisory RHSA-2026:56969 vom 2026-08-20 access.redhat.com
- Rocky Linux Security Advisory RLSA-2026:57539 vom 2026-08-20 errata.build.resf.org
- Red Hat Security Advisory RHSA-2026:57539 vom 2026-08-20 access.redhat.com
- Rocky Linux Security Advisory RLSA-2026:56969 vom 2026-08-20 errata.build.resf.org
- Red Hat Security Advisory RHSA-2026:57574 vom 2026-08-20 access.redhat.com
- Rocky Linux Security Advisory RLSA-2026:57574 vom 2026-08-21 errata.build.resf.org
and 17 more sources in the original advisory
CVE: CVE-2026-17543, CVE-2026-17544, CVE-2026-7260
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.