NGINX-UI: Mehrere Schwachstellen
WID-SEC-2026-2798 · first 12.08.2026 · updated 12.10.2026 · CVSS 9,6
What it is about
nginx-ui ist eine Open-Source-Weboberfläche zur Verwaltung und Konfiguration von Nginx-Webservern. Ein Angreifer kann mehrere Schwachstellen in NGINX-UI ausnutzen, um erweiterte Berechtigungen zu erlangen, beliebigen Code – auch mit Root-Rechten – auszuführen, Sicherheitsmaßnahmen zu umgehen, sensible Daten offenzulegen oder einen Denial-of-Service-Zustand auszulösen.
Under what conditions?
The BSI does not name any particular preconditions. Exploitable remotely according to the BSI.
What can happen in the worst case
An attacker could use the vulnerability to
- erweiterte Berechtigungen zu erlangen
- beliebigen Code – auch mit Root-Rechten – auszuführen
- Sicherheitsmaßnahmen zu umgehen
- sensible Daten offenzulegen oder einen Denial-of-Service-Zustand auszulösen
Am I affected?
Affected according to the BSI:
- Open Source nginx-ui <2.5.0
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source nginx-ui 2.5.0
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- GitHub Security Advisory GHSA-33rr-wq23-g6gg vom 2026-08-11 github.com
- GitHub Security Advisory GHSA-45gv-9wjv-xh7p vom 2026-08-11 github.com
- GitHub Security Advisory GHSA-662p-52hx-cmh2 vom 2026-08-11 github.com
- GitHub Security Advisory GHSA-746f-pjq6-cc8p vom 2026-08-11 github.com
- GitHub Security Advisory GHSA-7mm5-v557-38qq vom 2026-08-11 github.com
- GitHub Security Advisory GHSA-h246-wpgf-vmq5 vom 2026-08-11 github.com
- GitHub Security Advisory GHSA-m9w2-f5px-x36p vom 2026-08-11 github.com
- GitHub Security Advisory GHSA-p393-cf76-4jmr vom 2026-08-11 github.com
- GitHub Security Advisory GHSA-p8v3-89rh-jxc7 vom 2026-08-11 github.com
- GitHub Security Advisory GHSA-pvgv-gcp7-v38g vom 2026-08-11 github.com
- GitHub Security Advisory GHSA-qfwj-23j7-6939 vom 2026-08-11 github.com
- GitHub Security Advisory GHSA-qq4p-5m6w-ww57 vom 2026-08-11 github.com
- GitHub Security Advisory GHSA-r7jh-46x8-grj8 vom 2026-08-11 github.com
- GitHub Security Advisory GHSA-32gc-wf3m-78w9 vom 2026-08-11 github.com
- GitHub Security Advisory GHSA-49r7-63h8-8p86 vom 2026-08-11 github.com
CVE: CVE-2026-107806, CVE-2026-107807, CVE-2026-107808, CVE-2026-107809, CVE-2026-107810, CVE-2026-107811, CVE-2026-107812, CVE-2026-107813
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.