Threat landscape
high

Composer: Mehrere Schwachstellen

WID-SEC-2026-3072 · first 28.08.2026 · updated 02.10.2026 · CVSS 8,8

×

What it is about

Composer ist ein Open-Source-Abhängigkeitsmanager für PHP-Projekte. Ein Angreifer kann mehrere Schwachstellen in Composer ausnutzen, um Sicherheitsvorkehrungen zu umgehenn und beliebigen Code auszuführen.

Under what conditions?

The BSI does not name any particular preconditions. Exploitable remotely according to the BSI.

What can happen in the worst case

An attacker could use the vulnerability to

  • Sicherheitsvorkehrungen zu umgehenn
  • beliebigen Code auszuführen

Am I affected?

Affected according to the BSI:

  • Red Hat Enterprise Linux
  • SUSE Linux
  • SUSE openSUSE
  • Open Source Composer <2.10.3
  • Open Source Composer <2.2.30

The installed version is usually shown under “Help → About” or in the device’s admin interface.

What helps?

Update to at least:

  • Open Source Composer 2.10.3
  • Open Source Composer 2.2.30

Is the vulnerability already being exploited?

None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.

Information and sources

CVE: CVE-2026-59944, CVE-2026-84361

Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.

Set up in an hour, trained in a week.

Create a free account, add your team, unlock the course. You only pay when you start. Would you rather see what a test email looks like first? The self-test is free.

Add your team Test it yourself first