Flowise: Mehrere Schwachstellen
WID-SEC-2026-3102 · first 01.09.2026 · updated 16.09.2026 · CVSS 9,9
What it is about
Flowise ist eine Benutzeroberfläche zur Erstellung von LLMs (Large Language Model). Ein Angreifer kann mehrere Schwachstellen in Flowise ausnutzen, um erweiterte Berechtigungen – einschließlich Administratorzugriff – zu erlangen, um beliebigen Code auszuführen, SQL-Injection durchzuführen, Sicherheitsmaßnahmen zu umgehen, Daten zu manipulieren oder offenzulegen oder einen Denial-of-Service-Zustand auszulösen.
Under what conditions?
The BSI does not name any particular preconditions. Exploitable remotely according to the BSI.
What can happen in the worst case
An attacker could use the vulnerability to
- erweiterte Berechtigungen – einschließlich Administratorzugriff – zu erlangen
- beliebigen Code auszuführen
- SQL-Injection durchzuführen
- Sicherheitsmaßnahmen zu umgehen
- Daten zu manipulieren oder offenzulegen oder einen Denial-of-Service-Zustand auszulösen
Am I affected?
Affected according to the BSI:
- Open Source Flowise <3.1.4
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source Flowise 3.1.4
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- GitHub Security Advisory GHSA-7x8x-vv46-4579 vom 2026-08-31 github.com
- GitHub Security Advisory GHSA-9cvr-5wv9-2gxr vom 2026-08-31 github.com
- GitHub Security Advisory GHSA-gggp-6qmf-xwwc vom 2026-08-31 github.com
- GitHub Security Advisory GHSA-hx55-h48h-7rw9 vom 2026-08-31 github.com
- GitHub Security Advisory GHSA-jrcq-qjw5-xx5q vom 2026-08-31 github.com
- GitHub Security Advisory GHSA-pprx-4prj-35mj vom 2026-08-31 github.com
- GitHub Security Advisory GHSA-pwfj-wh95-7mwp vom 2026-08-31 github.com
- GitHub Security Advisory GHSA-vcwp-f9rq-3887 vom 2026-08-31 github.com
- GitHub Security Advisory GHSA-vrr6-xgc3-j99r vom 2026-08-31 github.com
- GitHub Security Advisory GHSA-wpvf-4vfx-rgxm vom 2026-08-31 github.com
- GitHub Security Advisory GHSA-x7x8-95gh-42xm vom 2026-08-31 github.com
CVE: CVE-2026-91929, CVE-2026-91930, CVE-2026-91931, CVE-2026-91932, CVE-2026-91933, CVE-2026-91934, CVE-2026-91935, CVE-2026-91936, CVE-2026-91937, CVE-2026-91938
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.