Threat landscape
high

Drupal Erweiterungen: Mehrere Schwachstellen

WID-SEC-2026-3168 · first 03.09.2026 · updated 22.10.2026 · CVSS 9,1

×

What it is about

Drupal ist ein freies Content-Management-System, basierend auf der Scriptsprache PHP und einer SQL-Datenbank. Über zahlreiche Extensions kann der Funktionsumfang der Core-Installation individuell erweitert werden. Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in verschiedenen Drupal Erweiterungen ausnutzen, um Zugriffsbeschränkungen zu umgehen, geschützte oder sensible Inhalte offenzulegen, Benutzerkonten zu übernehmen, unberechtigte Änderungen oder Löschungen vorzunehmen, Zahlungsstatus zu manipulieren sowie Cross-Site-Scripting-Angriffe auszuführen.

Under what conditions?

Over the network and without logging in. This is the most dangerous combination: attackers can scan reachable devices automatically.

What can happen in the worst case

An attacker could use the vulnerability to

  • Zugriffsbeschränkungen zu umgehen
  • geschützte oder sensible Inhalte offenzulegen
  • Benutzerkonten zu übernehmen
  • unberechtigte Änderungen oder Löschungen vorzunehmen
  • Zahlungsstatus zu manipulieren sowie Cross-Site-Scripting-Angriffe auszuführen

Am I affected?

Affected according to the BSI:

  • Open Source Drupal AI <1.4.8
  • Open Source Drupal Advanced Search <2.4.5
  • Open Source Drupal AI Translate <1.4.1
  • Open Source Drupal Calculate Working Days <2.0.3
  • Open Source Drupal Component Blocks <1.2.7
  • Open Source Drupal Email Verification / SMS Verification / OTP Verification <2.4.0
  • Open Source Drupal Islandora <2.19.0
  • Open Source Drupal Jsonapi Role Access <2.0.2
  • Open Source Drupal Mailer Plus Log <1.2.7
  • Open Source Drupal Media Library Importer <2.1.6
  • Open Source Drupal Monobank Payment API <1.0.3
  • Open Source Drupal PhotoSwipe <5.0.9

and 2 more

The installed version is usually shown under “Help → About” or in the device’s admin interface.

What helps?

Update to at least:

  • Open Source Drupal AI 1.4.8
  • Open Source Drupal Advanced Search 2.4.5
  • Open Source Drupal AI Translate 1.4.1
  • Open Source Drupal Calculate Working Days 2.0.3
  • Open Source Drupal Component Blocks 1.2.7
  • Open Source Drupal Email Verification / SMS Verification / OTP Verification 2.4.0
  • Open Source Drupal Islandora 2.19.0
  • Open Source Drupal Jsonapi Role Access 2.0.2
  • Open Source Drupal Mailer Plus Log 1.2.7
  • Open Source Drupal Media Library Importer 2.1.6
  • Open Source Drupal Monobank Payment API 1.0.3
  • Open Source Drupal PhotoSwipe 5.0.9

Is the vulnerability already being exploited?

None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.

Information and sources

CVE: CVE-2026-16648, CVE-2026-81163, CVE-2026-84910, CVE-2026-84911, CVE-2026-84912, CVE-2026-84913, CVE-2026-84914, CVE-2026-84915, CVE-2026-84916, CVE-2026-84917, CVE-2026-84918, CVE-2026-84919, CVE-2026-84920, CVE-2026-84921, CVE-2026-84923, CVE-2026-84924

Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.

Set up in an hour, trained in a week.

Create a free account, add your team, unlock the course. You only pay when you start. Would you rather see what a test email looks like first? The self-test is free.

Add your team Test it yourself first