PHP: Mehrere Schwachstellen
WID-SEC-2026-3585 · first 25.09.2026 · updated 26.10.2026 · CVSS 7,5
What it is about
PHP ist eine Programmiersprache, die zur Implementierung von Web-Applikationen genutzt wird. Ein Angreifer kann mehrere Schwachstellen in PHP ausnutzen, um einen Denial of Service Angriff durchzuführen, um Informationen offenzulegen oder die Integrität zu verletzen.
Under what conditions?
The BSI does not name any particular preconditions. Exploitable remotely according to the BSI.
What can happen in the worst case
An attacker could use the vulnerability to
- einen Denial of Service Angriff durchzuführen
- Informationen offenzulegen oder die Integrität zu verletzen
Am I affected?
Affected according to the BSI:
- Debian Linux
- Amazon Linux 2
- Red Hat Enterprise Linux
- RESF Rocky Linux
- SUSE Linux
- SUSE openSUSE
- Oracle Linux
- Zend ZendPHP
- Open Source PHP <8.3.35
- Open Source PHP <8.2.34
- Open Source PHP <8.4.26
- Open Source PHP <8.5.11
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source PHP 8.3.35
- Open Source PHP 8.2.34
- Open Source PHP 8.4.26
- Open Source PHP 8.5.11
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- PHP 8 ChangeLog vom 2026-09-24 php.net
- GitHub Security Advisory GHSA-7875-c8px-7q5f vom 2026-09-24 github.com
- GitHub Security Advisory GHSA-88hq-2827-7pg6 vom 2026-09-24 github.com
- GitHub Security Advisory GHSA-9f67-6fw4-hpfp vom 2026-09-24 github.com
- GitHub Security Advisory GHSA-ch8v-r6jh-4vvr vom 2026-09-24 github.com
- GitHub Security Advisory GHSA-cj93-vc83-wgqv vom 2026-09-24 github.com
- GitHub Security Advisory GHSA-fpwc-w8rq-cr92 vom 2026-09-24 github.com
- GitHub Security Advisory GHSA-j3wh-g957-2m85 vom 2026-09-24 github.com
- GitHub Security Advisory GHSA-r6x9-5r99-36j7 vom 2026-09-24 github.com
- GitHub Security Advisory GHSA-rgrp-mwpx-f6rm vom 2026-09-24 github.com
- GitHub Security Advisory GHSA-vvx9-73fr-5jjx vom 2026-09-24 github.com
- GitHub Security Advisory GHSA-xr7j-rvgx-xq5p vom 2026-09-24 github.com
- PHP 8 ChangeLog vom 2026-09-24 php.net
- Red Hat Security Advisory RHSA-2026:70720 vom 2026-09-25 access.redhat.com
- Debian Security Advisory DSA-6514 vom 2026-09-28 security-tracker.debian.org
- openSUSE Security Update OPENSUSE-SU-2026:11901-1 vom 2026-10-01 lists.opensuse.org
- Debian Security Advisory DLA-4819 vom 2026-10-05 lists.debian.org
- Zend Security Updates vom 2026-10-07 www.zend.com
- SUSE Security Update SUSE-SU-2026:4603-1 vom 2026-10-09 lists.suse.com
- SUSE Security Update SUSE-SU-2026:4602-1 vom 2026-10-09 lists.suse.com
- Amazon Linux Security Advisory ALAS2PHP8.2-2026-014 vom 2026-10-13 alas.aws.amazon.com
- SUSE Security Update SUSE-SU-2026:4651-1 vom 2026-10-14 lists.suse.com
- SUSE Security Update SUSE-SU-2026:24158-1 vom 2026-10-15 lists.suse.com
- openSUSE Security Update OPENSUSE-SU-2026:22045-1 vom 2026-10-18 lists.opensuse.org
- Red Hat Security Advisory RHSA-2026:87151 vom 2026-10-21 access.redhat.com
and 21 more sources in the original advisory
CVE: CVE-2025-1218, CVE-2025-14181, CVE-2026-17545, CVE-2026-6103, CVE-2026-91765, CVE-2026-91766, CVE-2026-91767, CVE-2026-91769, CVE-2026-92842, CVE-2026-93682
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.