Langflow: Mehrere Schwachstellen
WID-SEC-2026-3616 · first 29.09.2026 · updated 06.10.2026 · CVSS 9,9
What it is about
Langflow bietet eine visuelle Schnittstelle zum Erstellen von LLM-basierten Anwendungen. Ein entfernter, authentisierter Angreifer kann mehrere Schwachstellen in Langflow ausnutzen, um Superuser-Rechte zu erlangen, beliebigen Code auszuführen, Sicherheitsmaßnahmen zu umgehen sowie Daten offenzulegen oder zu manipulieren.
Under what conditions?
Over the network, but only with valid access (login required), for example with stolen credentials or as an insider.
What can happen in the worst case
An attacker could use the vulnerability to
- Superuser-Rechte zu erlangen
- beliebigen Code auszuführen
- Sicherheitsmaßnahmen zu umgehen sowie Daten offenzulegen oder zu manipulieren
Am I affected?
Affected according to the BSI:
- Open Source Langflow <1.12.0
- Open Source Langflow <1.12.3
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source Langflow 1.12.0
- Open Source Langflow 1.12.3
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- Langflow Releases vom 2026-09-28 github.com
- GitHub Security Advisory GHSA-w794-rj3p-xv45 vom 2026-09-28 github.com
- GitHub Security Advisory GHSA-33p4-w7j3-33mw vom 2026-09-28 github.com
- GitHub Security Advisory GHSA-8qpj-27x8-pwpq vom 2026-09-28 github.com
- GitHub Security Advisory GHSA-gh98-4phw-6fmw vom 2026-09-28 github.com
- GitHub Security Advisory GHSA-j8f7-x8jm-wmm4 vom 2026-09-28 github.com
CVE: CVE-2026-101861, CVE-2026-105697, CVE-2026-105698
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.