LiteLLM: Schwachstelle ermöglicht Privilegieneskalation und Codeausführung
WID-SEC-2026-3644 · first 30.09.2026 · updated 23.10.2026 · CVSS 9,9
What it is about
LiteLLM ist ein Gateway, das eine einheitliche Schnittstelle für verschiedene Large Language Models (LLMs) bietet. Ein entfernter, authentisierter Angreifer kann eine Schwachstelle in LiteLLM ausnutzen, um seine Privilegien zu erhöhen, und um beliebigen Programmcode auszuführen.
Under what conditions?
Over the network, but only with valid access (login required), for example with stolen credentials or as an insider.
What can happen in the worst case
An attacker could use the vulnerability to
- seine Privilegien zu erhöhen
- beliebigen Programmcode auszuführen
Am I affected?
Affected according to the BSI:
- Open Source LiteLLM <1.100.4
- Open Source LiteLLM <1.101.3
- Open Source LiteLLM <1.102.2
- Open Source LiteLLM <1.103.1
- Open Source LiteLLM <1.104.0rc2
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source LiteLLM 1.100.4
- Open Source LiteLLM 1.101.3
- Open Source LiteLLM 1.102.2
- Open Source LiteLLM 1.103.1
- Open Source LiteLLM 1.104.0rc2
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
CVE: CVE-2026-114612
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.