nginx-ui: Mehrere Schwachstellen
WID-SEC-2026-3668 · first 30.09.2026 · updated 12.10.2026 · CVSS 8,8
What it is about
nginx-ui ist eine Open-Source-Weboberfläche zur Verwaltung und Konfiguration von Nginx-Webservern. Ein entfernter Angreifer kann mehrere Schwachstellen in nginx-ui ausnutzen, um Administratorrechte zu erlangen, um Sicherheitsmechanismen zu umgehen, um Informationen offenzulegen oder zu manipulieren, sowie um einen Denial of Service herbeizuführen.
Under what conditions?
Over the network.
What can happen in the worst case
An attacker could use the vulnerability to
- Administratorrechte zu erlangen
- Sicherheitsmechanismen zu umgehen
- Informationen offenzulegen oder zu manipulieren
- sowie um einen Denial of Service herbeizuführen
Am I affected?
Affected according to the BSI:
- Open Source nginx-ui <2.6.2
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source nginx-ui 2.6.2
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- GitHub Security Advisory GHSA-94h5-jw58-qqq8 vom 2026-09-29 github.com
- GitHub Security Advisory GHSA-9h23-53f4-q947 vom 2026-09-29 github.com
- GitHub Security Advisory GHSA-gp79-j356-rr7m vom 2026-09-29 github.com
- GitHub Security Advisory GHSA-j3hg-9rp3-5hw9 vom 2026-09-29 github.com
- GitHub Security Advisory GHSA-pw4f-pq6v-x57r vom 2026-09-29 github.com
- GitHub Security Advisory GHSA-rg7q-q2cr-372q vom 2026-09-29 github.com
- GitHub Security Advisory GHSA-x2x3-p8j2-63mx vom 2026-09-29 github.com
- GitHub Security Advisory GHSA-xrj8-9g8p-mc7v vom 2026-09-29 github.com
CVE: CVE-2026-107804, CVE-2026-107805
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.