Threat landscape
high

Apache Struts: Mehrere Schwachstellen

WID-SEC-2026-3723 · first 05.10.2026 · updated 16.10.2026 · CVSS 9,8

×

What it is about

Struts ist ein Framework für Java-Anwendungen auf dem Webserver Apache. Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in Apache Struts ausnutzen, um beliebigen Programmcode auszuführen, vertrauliche Informationen offenzulegen oder einen Denial-of-Service-Zustand zu verursachen.

Under what conditions?

Over the network and without logging in. This is the most dangerous combination: attackers can scan reachable devices automatically.

What can happen in the worst case

An attacker could use the vulnerability to

  • beliebigen Programmcode auszuführen
  • vertrauliche Informationen offenzulegen oder einen Denial-of-Service-Zustand zu verursachen

Am I affected?

Affected according to the BSI:

  • IBM Tivoli Netcool/OMNIbus
  • Apache Struts <7.4.0
  • Apache Struts <6.12.0

The installed version is usually shown under “Help → About” or in the device’s admin interface.

What helps?

Update to at least:

  • Apache Struts 7.4.0
  • Apache Struts 6.12.0

Is the vulnerability already being exploited?

None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.

Information and sources

CVE: CVE-2026-104711, CVE-2026-104712, CVE-2026-104713, CVE-2026-104714

Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.

Set up in an hour, trained in a week.

Create a free account, add your team, unlock the course. You only pay when you start. Would you rather see what a test email looks like first? The self-test is free.

Add your team Test it yourself first