Gradle: Mehrere Schwachstellen
WID-SEC-2026-3805 · first 08.10.2026 · updated 08.10.2026 · CVSS 8,2
What it is about
Gradle ist ein Open-Source-Build-Automatisierungstool, das mehrere Programmiersprachen und Plattformen unterstützt und sich auf Flexibilität und Leistung konzentriert. Ein Angreifer kann mehrere Schwachstellen in Gradle ausnutzen, um beliebigen Code mit den Berechtigungen des ausführenden Build-Benutzers auszuführen, vertrauliche Informationen auszulesen oder einen Denial of Service auszulösen.
Under what conditions?
The BSI does not name any particular preconditions.
What can happen in the worst case
An attacker could use the vulnerability to
- beliebigen Code mit den Berechtigungen des ausführenden Build-Benutzers auszuführen
- vertrauliche Informationen auszulesen oder einen Denial of Service auszulösen
Am I affected?
Affected according to the BSI:
- Open Source Gradle <8.14.6
- Open Source Gradle <9.8.1
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source Gradle 8.14.6
- Open Source Gradle 9.8.1
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- GitHub Security Advisory GHSA-j5m7-59rp-24f5 vom 2026-10-07 github.com
- GitHub Security Advisory GHSA-mvvg-497x-hmj8 vom 2026-10-07 github.com
- GitHub Security Advisory GHSA-xwqc-3h47-hg64 vom 2026-10-07 github.com
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.