Threat landscape
critical

Drupal Erweiterungen: Mehrere Schwachstellen

WID-SEC-2026-3819 · first 09.10.2026 · updated 09.10.2026 · CVSS 9,8

×

What it is about

Drupal ist ein freies Content-Management-System, basierend auf der Scriptsprache PHP und einer SQL-Datenbank. Über zahlreiche Extensions kann der Funktionsumfang der Core-Installation individuell erweitert werden. Ein Angreifer kann mehrere Schwachstellen in Drupal ausnutzen, um beliebigen Programmcode auszuführen, erweiterte Berechtigungen zu erlangen, Sicherheitsmaßnahmen zu umgehen, Daten zu manipulieren und offenzulegen oder Cross-Site-Scripting-Angriffe durchzuführen.

Under what conditions?

The BSI does not name any particular preconditions. Exploitable remotely according to the BSI.

What can happen in the worst case

An attacker could use the vulnerability to

  • beliebigen Programmcode auszuführen
  • erweiterte Berechtigungen zu erlangen
  • Sicherheitsmaßnahmen zu umgehen
  • Daten zu manipulieren
  • offenzulegen oder Cross-Site-Scripting-Angriffe durchzuführen

Am I affected?

Affected according to the BSI:

  • Open Source Drupal Block AJAX <3.0.2
  • Open Source Drupal Entity Reference Manager (Merge entities) <1.0.3
  • Open Source Drupal MathJax: LaTeX <4.1.2
  • Open Source Drupal Authenticator Login Plus (2FA) <1.0.1
  • Open Source Drupal Actstream <2.0.1
  • Open Source Drupal Actstream <2.1.1
  • Open Source Drupal Inline Entity Form Dialog <1.0.6
  • Open Source Drupal Linked Field <1.8.0
  • Open Source Drupal Gutenberg <2.15.0
  • Open Source Drupal Gutenberg <3.0.7
  • Open Source Drupal Inline Formatter Field <4.2.0
  • Open Source Drupal Leaflet <10.4.13

and 21 more

The installed version is usually shown under “Help → About” or in the device’s admin interface.

What helps?

Update to at least:

  • Open Source Drupal Block AJAX 3.0.2
  • Open Source Drupal Entity Reference Manager (Merge entities) 1.0.3
  • Open Source Drupal MathJax: LaTeX 4.1.2
  • Open Source Drupal Authenticator Login Plus (2FA) 1.0.1
  • Open Source Drupal Actstream 2.0.1
  • Open Source Drupal Actstream 2.1.1
  • Open Source Drupal Inline Entity Form Dialog 1.0.6
  • Open Source Drupal Linked Field 1.8.0
  • Open Source Drupal Gutenberg 2.15.0
  • Open Source Drupal Gutenberg 3.0.7
  • Open Source Drupal Inline Formatter Field 4.2.0
  • Open Source Drupal Leaflet 10.4.13

Is the vulnerability already being exploited?

None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.

Information and sources

and 2 more sources in the original advisory

CVE: CVE-2026-107249, CVE-2026-107251, CVE-2026-107252, CVE-2026-107254, CVE-2026-107255, CVE-2026-107257, CVE-2026-107258, CVE-2026-107259, CVE-2026-107261, CVE-2026-107262, CVE-2026-107263, CVE-2026-107264, CVE-2026-107265, CVE-2026-107266, CVE-2026-107267, CVE-2026-107306, CVE-2026-107307, CVE-2026-107308, CVE-2026-107309, CVE-2026-107310 …

Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.

Set up in an hour, trained in a week.

Create a free account, add your team, unlock the course. You only pay when you start. Would you rather see what a test email looks like first? The self-test is free.

Add your team Test it yourself first