Ollama: Schwachstelle ermöglicht Codeausführung
WID-SEC-2026-3821 · first 09.10.2026 · updated 09.10.2026 · CVSS 10,0
What it is about
Ollama ist eine Open-Source-Runtime zum lokalen Ausführen von Large Language Models (LLMs) Ein entfernter, anonymer Angreifer kann eine Schwachstelle in Ollama ausnutzen, um beliebigen Programmcode mit root Rechten auszuführen.
Under what conditions?
Over the network and without logging in. This is the most dangerous combination: attackers can scan reachable devices automatically.
What can happen in the worst case
An attacker could use the vulnerability to
- beliebigen Programmcode mit root Rechten auszuführen
Am I affected?
Affected according to the BSI:
- Ollama Ollama <0.35.0
- Ollama Ollama >=0.34.2
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Ollama Ollama 0.35.0
- Ollama Ollama >=0.34.2
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- CERT Polska vom 2026-10-08 cert.pl
- EU Vulnerability Database vom 2026-10-08 euvd.enisa.europa.eu
- Github advisory database github.com
CVE: CVE-2026-103663
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.