vllm: Mehrere Schwachstellen
WID-SEC-2026-3828 · first 09.10.2026 · updated 26.10.2026 · CVSS 7,7
What it is about
Open Source vLLM ist eine Open-Source-Bibliothek für schnelle und effiziente Inferenz von Large Language Models (LLMs). Ein entfernter, authentisierter Angreifer kann mehrere Schwachstellen in vllm ausnutzen, um einen Denial of Service Angriff durchzuführen und um Informationen offenzulegen.
Under what conditions?
Over the network, but only with valid access (login required), for example with stolen credentials or as an insider.
What can happen in the worst case
An attacker could use the vulnerability to
- einen Denial of Service Angriff durchzuführen
- Informationen offenzulegen
Am I affected?
Affected according to the BSI:
- Open Source vllm <0.18.0
- Open Source vllm <0.24.0
- Open Source vllm <0.29.0
- Open Source vllm <0.30.0
- Open Source vllm <0.25.0
- Open Source vllm <0.31.0
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source vllm 0.18.0
- Open Source vllm 0.24.0
- Open Source vllm 0.29.0
- Open Source vllm 0.30.0
- Open Source vllm 0.25.0
- Open Source vllm 0.31.0
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- GitHub Security Advisory GHSA-34qw-q2h2-jp3m vom 2026-10-08 github.com
- GitHub Security Advisory GHSA-4m6g-h9mv-wqjc vom 2026-10-08 github.com
- GitHub Security Advisory GHSA-6pgw-f3pv-4h8q vom 2026-10-08 github.com
- GitHub Security Advisory GHSA-8c65-hq7q-r7jm vom 2026-10-08 github.com
- GitHub Security Advisory GHSA-mm38-5g96-7j6x vom 2026-10-08 github.com
- GitHub Security Advisory GHSA-rhcx-5729-88vg vom 2026-10-08 github.com
- GitHub Security Advisory GHSA-rwfw-xvg3-3937 vom 2026-10-08 github.com
- GitHub Security Advisory GHSA-vfp2-c8pq-v6h6 vom 2026-10-08 github.com
- GitHub Security Advisory GHSA-w2v2-5662-8v5q vom 2026-10-08 github.com
- GitHub Security Advisory GHSA-w9r6-29q4-pvpr vom 2026-10-08 github.com
CVE: CVE-2026-116172, CVE-2026-116173, CVE-2026-116176, CVE-2026-116177, CVE-2026-116178, CVE-2026-116179, CVE-2026-116180
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.