JHipster: Mehrere Schwachstellen
WID-SEC-2026-3842 · first 09.10.2026 · updated 09.10.2026 · CVSS 8,8
What it is about
JHipster ist eine Java-Entwicklungsplattform zur Generierung, Entwicklung und Bereitstellung von Webanwendungen und Mikroservice-Architekturen. Ein entfernter, authentisierter Angreifer kann mehrere Schwachstellen in JHipster ausnutzen, um einen Cross-Site Scripting Angriff durchzuführen oder eine SQL-Injection durchzuführen.
Under what conditions?
Over the network, but only with valid access (login required), for example with stolen credentials or as an insider.
What can happen in the worst case
An attacker could use the vulnerability to
- einen Cross-Site Scripting Angriff durchzuführen oder eine SQL-Injection durchzuführen
Am I affected?
Affected according to the BSI:
- Open Source JHipster <1.1.0
- Open Source JHipster <9.4.0
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source JHipster 1.1.0
- Open Source JHipster 9.4.0
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- GitHub Security Advisory GHSA-9ffp-22j7-56r2 vom 2026-10-08 github.com
- GitHub Security Advisory GHSA-r223-96jv-q533 vom 2026-10-08 github.com
CVE: CVE-2026-107303, CVE-2026-107375
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.