Threat landscape
high exploited

Apache Struts: Mehrere Schwachstellen ermöglichen Ausführen von beliebigem Programmcode mit den Rechten des Dienstes

WID-SEC-2026-3852 · first 25.04.2016 · updated 12.10.2026 · CVSS 8,8

×

What it is about

Struts ist ein Framework für Java-Anwendungen auf dem Webserver Apache. Ein entfernter, authentisierter Angreifer kann mehrere Schwachstellen in Apache Struts ausnutzen, um beliebigen Programmcode mit den Rechten des Dienstes auszuführen.

Under what conditions?

Over the network, but only with valid access (login required), for example with stolen credentials or as an insider.

What can happen in the worst case

An attacker could use the vulnerability to

  • beliebigen Programmcode mit den Rechten des Dienstes auszuführen

Am I affected?

Affected according to the BSI:

  • Apache Struts 2.0.0
  • Apache Struts <2.3.20.2
  • Apache Struts <2.3.24.2
  • Apache Struts <2.3.28.1

The installed version is usually shown under “Help → About” or in the device’s admin interface.

What helps?

Update to at least:

  • Apache Struts 2.3.20.2
  • Apache Struts 2.3.24.2
  • Apache Struts 2.3.28.1

Is the vulnerability already being exploited?

Information and sources

CVE: CVE-2016-3081, CVE-2016-3082

Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.

Set up in an hour, trained in a week.

Create a free account, add your team, unlock the course. You only pay when you start. Would you rather see what a test email looks like first? The self-test is free.

Add your team Test it yourself first