vim: Mehrere Schwachstellen ermöglichen Ausführen von beliebigem Programmcode mit Benutzerrechten
WID-SEC-2026-3876 · first 13.10.2026 · updated 13.10.2026 · CVSS 7,8
What it is about
Vim (Vi IMproved) ist eine Weiterentwicklung des Texteditors vi. Ein Angreifer kann mehrere Schwachstellen in vim ausnutzen, um beliebigen Programmcode mit Benutzerrechten auszuführen.
Under what conditions?
The BSI does not name any particular preconditions.
What can happen in the worst case
An attacker could use the vulnerability to
- beliebigen Programmcode mit Benutzerrechten auszuführen
Am I affected?
Affected according to the BSI:
- Open Source vim <v9.2.1178
- Open Source vim <v9.2.1177
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source vim v9.2.1178
- Open Source vim v9.2.1177
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- GitHub Security Advisory GHSA-4xgr-vqh2-xfx8 vom 2026-10-12 github.com
- GitHub Security Advisory GHSA-x2w5-pj55-7hpc vom 2026-10-12 github.com
- OSS Security Mailing List vom 2026-10-12 seclists.org
- OSS Security Mailing List vom 2026-10-12 seclists.org
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.