NGINX: Mehrere Schwachstellen
WID-SEC-2026-3948 · first 15.10.2026 · updated 27.10.2026 · CVSS 8,8
What it is about
NGINX Plus ist die kommerzielle Variante von NGINX, einer Webserver-, Reverse Proxy- und E-Mail Proxy Software. NGINX ist eine Webserver-, Reverse Proxy- und E-Mail-Proxy Software. Ein Angreifer kann mehrere Schwachstellen in NGINX NGINX Plus und NGINX ausnutzen, um beliebigen Programmcode auszuführen, Sicherheitsmaßnahmen zu umgehen, Daten zu manipulieren und offenzulegen oder einen Denial-of-Service-Zustand auszulösen.
Under what conditions?
The BSI does not name any particular preconditions. Exploitable remotely according to the BSI.
What can happen in the worst case
An attacker could use the vulnerability to
- beliebigen Programmcode auszuführen
- Sicherheitsmaßnahmen zu umgehen
- Daten zu manipulieren
- offenzulegen oder einen Denial-of-Service-Zustand auszulösen
Am I affected?
Affected according to the BSI:
- Debian Linux
- Amazon Linux 2
- Red Hat Enterprise Linux
- Ubuntu Linux
- NGINX NGINX Plus <37.1.0.1
- NGINX NGINX Plus <37.0.5.1
- NGINX NGINX Open Source <1.31.7
- NGINX NGINX Open Source <1.30.6
- NGINX NGINX Instance Manager <2.24.0
- NGINX NGINX F5 WAF <5.16.0
- NGINX NGINX F5 WAF <5.14.2
- NGINX NGINX F5 DoS <4.11.0
and 7 more
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- NGINX NGINX Plus 37.1.0.1
- NGINX NGINX Plus 37.0.5.1
- NGINX NGINX Open Source 1.31.7
- NGINX NGINX Open Source 1.30.6
- NGINX NGINX Instance Manager 2.24.0
- NGINX NGINX F5 WAF 5.16.0
- NGINX NGINX F5 WAF 5.14.2
- NGINX NGINX F5 DoS 4.11.0
- NGINX NGINX Gateway Fabric 2.8.0
- NGINX NGINX Ingress Controller 5.7.0
- NGINX NGINX Plus 37.2.0.1
- NGINX NGINX Plus 37.0.7.1
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- GitHub Advisory Database vom 2026-10-14 github.com
- GitHub Advisory Database vom 2026-10-14 github.com
- GitHub Advisory Database vom 2026-10-14 github.com
- GitHub Advisory Database vom 2026-10-14 github.com
- GitHub Advisory Database vom 2026-10-14 github.com
- GitHub Advisory Database vom 2026-10-14 github.com
- GitHub Advisory Database vom 2026-10-14 github.com
- GitHub Advisory Database vom 2026-10-14 github.com
- GitHub Advisory Database vom 2026-10-14 github.com
- GitHub Advisory Database vom 2026-10-14 github.com
- GitHub Advisory Database vom 2026-10-14 github.com
- F5 Security Advisory vom 2026-10-14 my.f5.com
- F5 Security Advisory vom 2026-10-14 my.f5.com
- F5 Security Advisory vom 2026-10-14 my.f5.com
- F5 Security Advisory vom 2026-10-14 my.f5.com
- F5 Security Advisory vom 2026-10-14 my.f5.com
- F5 Security Advisory vom 2026-10-14 my.f5.com
- F5 Security Advisory vom 2026-10-14 my.f5.com
- F5 Security Advisory vom 2026-10-14 my.f5.com
- Red Hat Security Advisory RHSA-2026:83427 vom 2026-10-16 access.redhat.com
- Debian Security Advisory DSA-6575 vom 2026-10-22 lists.debian.org
- Amazon Linux Security Advisory ALAS2NGINX1-2026-017 vom 2026-10-25 alas.aws.amazon.com
- Ubuntu Security Notice USN-8955-1 vom 2026-10-26 ubuntu.com
CVE: CVE-2026-15176, CVE-2026-93479, CVE-2026-95101, CVE-2026-97205, CVE-2026-97629, CVE-2026-91184, CVE-2026-96615, CVE-2026-104939, CVE-2026-94197, CVE-2026-101019, CVE-2026-101025
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.